package/mplayer: add optional rtmpdump support
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 29 Mar 2015 17:11:28 +0000 (19:11 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 8 Apr 2015 21:00:34 +0000 (23:00 +0200)
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/mplayer/mplayer.mk

index 46bc2b078b605c240bff7ccfeaa1e39e7c6e08e1..412837dc7ac4a06f7c6fa2d5c2b6f699bf7e6884 100644 (file)
@@ -166,6 +166,14 @@ else
 MPLAYER_CONF_OPTS += --disable-gif
 endif
 
+# We intentionally don't pass --enable-librtmp to let autodetection
+# find which library to link with.
+ifeq ($(BR2_PACKAGE_RTMPDUMP),y)
+MPLAYER_DEPENDENCIES += rtmpdump
+else
+MPLAYER_CONF_OPTS += --disable-librtmp
+endif
+
 ifeq ($(BR2_PACKAGE_LZO),y)
 MPLAYER_DEPENDENCIES += lzo
 MPLAYER_CONF_OPTS += --enable-liblzo