wpa_supplicant: add support for simple background scan
authorMartin Bark <martin@barkynet.com>
Sat, 11 Jun 2016 16:13:09 +0000 (17:13 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 28 Jun 2016 19:55:46 +0000 (21:55 +0200)
CONFIG_BGSCAN_SIMPLE is missing from the defconfig included with
wpa_supplicant.  Many programs that depend on wpa_supplicant assume
bgscan is enabled, for example connman will try to set bgscan by default.
It is safe to always enable CONFIG_BGSCAN_SIMPLE since it is only used if
wpa_supplicant is configured to do so.

Signed-off-by: Martin Bark <martin@barkynet.com>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/wpa_supplicant/wpa_supplicant.mk

index ba1180d4b60874599bfe1fabfae0d479bb2254f8..21bbd3e5a939be53197e96fd044624ad1548970f 100644 (file)
@@ -20,7 +20,8 @@ WPA_SUPPLICANT_INSTALL_STAGING = YES
 
 WPA_SUPPLICANT_CONFIG_EDITS =
 
-WPA_SUPPLICANT_CONFIG_SET =
+# Add support for simple background scan
+WPA_SUPPLICANT_CONFIG_SET = CONFIG_BGSCAN_SIMPLE
 
 WPA_SUPPLICANT_CONFIG_ENABLE = \
        CONFIG_IEEE80211AC      \