Update kernel to 2.4.26-pre5
authorEric Andersen <andersen@codepoet.org>
Sun, 21 Mar 2004 01:58:59 +0000 (01:58 -0000)
committerEric Andersen <andersen@codepoet.org>
Sun, 21 Mar 2004 01:58:59 +0000 (01:58 -0000)
19 files changed:
make/linux.mk
sources/kernel-patches/001-patch-2.4.26-pre5.bz2 [new file with mode: 0644]
sources/kernel-patches/002_readahead.bz2 [deleted file]
sources/kernel-patches/005-ieee1394.bz2 [deleted file]
sources/kernel-patches/010-optimize-for-size.bz2
sources/kernel-patches/011_lowlatency-fixes-13.bz2 [deleted file]
sources/kernel-patches/041-changeloop.patch.bz2 [new file with mode: 0644]
sources/kernel-patches/042-loopfixes.patch.bz2 [new file with mode: 0644]
sources/kernel-patches/044-streaming_io.bz2 [new file with mode: 0644]
sources/kernel-patches/044_streaming_io.bz2 [deleted file]
sources/kernel-patches/063-silence.kbd.patch.bz2 [new file with mode: 0644]
sources/kernel-patches/063-silence.patch.bz2 [deleted file]
sources/kernel-patches/064-shutup-md.bz2 [new file with mode: 0644]
sources/kernel-patches/076_nmap-freak.bz2 [deleted file]
sources/kernel-patches/078-hostap.bz2 [new file with mode: 0644]
sources/kernel-patches/078_hostap.bz2 [deleted file]
sources/kernel-patches/079-jiffies64.bz2 [new file with mode: 0644]
sources/kernel-patches/100_VERSION.bz2
sources/linux.config

index cb5998cf0460f1f61c4052a5d58a00ce3bc5b595..c18ff86b63a80309d2c3ad2bef73156d41807c0f 100644 (file)
@@ -22,9 +22,9 @@
 ifneq ($(filter $(TARGETS),linux),)
 
 # Version of Linux to download and then apply patches to
-DOWNLOAD_LINUX_VERSION=2.4.23
+DOWNLOAD_LINUX_VERSION=2.4.25
 # Version of Linux AFTER patches
-LINUX_VERSION=2.4.23-erik
+LINUX_VERSION=2.4.25-pre5-erik
 
 LINUX_FORMAT=bzImage
 #LINUX_FORMAT=images/zImage.prep
@@ -48,6 +48,7 @@ $(DL_DIR)/$(LINUX_SOURCE):
         $(WGET) -P $(DL_DIR) $(LINUX_SITE)/$(LINUX_SOURCE)
 
 $(LINUX_DIR)/.unpacked: $(DL_DIR)/$(LINUX_SOURCE)
+       mkdir -p $(LINUX_DIR) $(TOOL_BUILD_DIR)
        rm -rf $(LINUX_DIR)
        bzcat $(DL_DIR)/$(LINUX_SOURCE) | tar -C $(BUILD_DIR) -xvf -
 ifneq ($(DOWNLOAD_LINUX_VERSION),$(LINUX_VERSION))
@@ -56,7 +57,7 @@ ifneq ($(DOWNLOAD_LINUX_VERSION),$(LINUX_VERSION))
 endif
        mkdir -p $(SOURCE_DIR)/kernel-patches
        $(SOURCE_DIR)/patch-kernel.sh $(LINUX_DIR) $(SOURCE_DIR)/kernel-patches
-       -(cd $(BUILD_DIR); ln -sf $(LINUX_DIR) linux)
+       -(cd $(TOOL_BUILD_DIR); ln -sf $(LINUX_DIR) linux)
        touch $(LINUX_DIR)/.unpacked
 
 $(LINUX_KCONFIG):
diff --git a/sources/kernel-patches/001-patch-2.4.26-pre5.bz2 b/sources/kernel-patches/001-patch-2.4.26-pre5.bz2
new file mode 100644 (file)
index 0000000..aa934c5
Binary files /dev/null and b/sources/kernel-patches/001-patch-2.4.26-pre5.bz2 differ
diff --git a/sources/kernel-patches/002_readahead.bz2 b/sources/kernel-patches/002_readahead.bz2
deleted file mode 100644 (file)
index 4102af7..0000000
Binary files a/sources/kernel-patches/002_readahead.bz2 and /dev/null differ
diff --git a/sources/kernel-patches/005-ieee1394.bz2 b/sources/kernel-patches/005-ieee1394.bz2
deleted file mode 100644 (file)
index ccf5d55..0000000
Binary files a/sources/kernel-patches/005-ieee1394.bz2 and /dev/null differ
index 904f6a9df4bc5ab1880214c6aad1081e7b27a2d6..68c19d4bbb1bf58fc84aa836d68e6ad3b1f698c8 100644 (file)
Binary files a/sources/kernel-patches/010-optimize-for-size.bz2 and b/sources/kernel-patches/010-optimize-for-size.bz2 differ
diff --git a/sources/kernel-patches/011_lowlatency-fixes-13.bz2 b/sources/kernel-patches/011_lowlatency-fixes-13.bz2
deleted file mode 100644 (file)
index a4caf01..0000000
Binary files a/sources/kernel-patches/011_lowlatency-fixes-13.bz2 and /dev/null differ
diff --git a/sources/kernel-patches/041-changeloop.patch.bz2 b/sources/kernel-patches/041-changeloop.patch.bz2
new file mode 100644 (file)
index 0000000..9e64eca
Binary files /dev/null and b/sources/kernel-patches/041-changeloop.patch.bz2 differ
diff --git a/sources/kernel-patches/042-loopfixes.patch.bz2 b/sources/kernel-patches/042-loopfixes.patch.bz2
new file mode 100644 (file)
index 0000000..456ee61
Binary files /dev/null and b/sources/kernel-patches/042-loopfixes.patch.bz2 differ
diff --git a/sources/kernel-patches/044-streaming_io.bz2 b/sources/kernel-patches/044-streaming_io.bz2
new file mode 100644 (file)
index 0000000..4f453e1
Binary files /dev/null and b/sources/kernel-patches/044-streaming_io.bz2 differ
diff --git a/sources/kernel-patches/044_streaming_io.bz2 b/sources/kernel-patches/044_streaming_io.bz2
deleted file mode 100644 (file)
index 5aadca5..0000000
Binary files a/sources/kernel-patches/044_streaming_io.bz2 and /dev/null differ
diff --git a/sources/kernel-patches/063-silence.kbd.patch.bz2 b/sources/kernel-patches/063-silence.kbd.patch.bz2
new file mode 100644 (file)
index 0000000..04c56d6
Binary files /dev/null and b/sources/kernel-patches/063-silence.kbd.patch.bz2 differ
diff --git a/sources/kernel-patches/063-silence.patch.bz2 b/sources/kernel-patches/063-silence.patch.bz2
deleted file mode 100644 (file)
index 04c56d6..0000000
Binary files a/sources/kernel-patches/063-silence.patch.bz2 and /dev/null differ
diff --git a/sources/kernel-patches/064-shutup-md.bz2 b/sources/kernel-patches/064-shutup-md.bz2
new file mode 100644 (file)
index 0000000..944b12a
Binary files /dev/null and b/sources/kernel-patches/064-shutup-md.bz2 differ
diff --git a/sources/kernel-patches/076_nmap-freak.bz2 b/sources/kernel-patches/076_nmap-freak.bz2
deleted file mode 100644 (file)
index 39483c6..0000000
Binary files a/sources/kernel-patches/076_nmap-freak.bz2 and /dev/null differ
diff --git a/sources/kernel-patches/078-hostap.bz2 b/sources/kernel-patches/078-hostap.bz2
new file mode 100644 (file)
index 0000000..f9ce7aa
Binary files /dev/null and b/sources/kernel-patches/078-hostap.bz2 differ
diff --git a/sources/kernel-patches/078_hostap.bz2 b/sources/kernel-patches/078_hostap.bz2
deleted file mode 100644 (file)
index be36ea2..0000000
Binary files a/sources/kernel-patches/078_hostap.bz2 and /dev/null differ
diff --git a/sources/kernel-patches/079-jiffies64.bz2 b/sources/kernel-patches/079-jiffies64.bz2
new file mode 100644 (file)
index 0000000..1b6873d
Binary files /dev/null and b/sources/kernel-patches/079-jiffies64.bz2 differ
index df7c10fc8174546365b7bebc677f235aa21cccfa..54d2e6571e4720adf6cde7ea16fdc7c9d11d5977 100644 (file)
Binary files a/sources/kernel-patches/100_VERSION.bz2 and b/sources/kernel-patches/100_VERSION.bz2 differ
index ee96b34d84476c6dd7d5000e38657572be15f985..e33656a9ff0ed4049b0433ff6287de077b30701f 100644 (file)
@@ -107,6 +107,7 @@ CONFIG_KCORE_ELF=y
 # CONFIG_BINFMT_AOUT is not set
 CONFIG_BINFMT_ELF=y
 # CONFIG_BINFMT_MISC is not set
+# CONFIG_OOM_KILLER is not set
 CONFIG_PM=y
 CONFIG_APM=y
 # CONFIG_APM_IGNORE_USER_SUSPEND is not set
@@ -195,7 +196,6 @@ CONFIG_IP_ROUTE_TOS=y
 # CONFIG_ARPD is not set
 CONFIG_INET_ECN=y
 # CONFIG_SYN_COOKIES is not set
-CONFIG_IP_NMAP_FREAK_PATCH=y
 
 #
 #   IP: Netfilter Configuration
@@ -261,6 +261,9 @@ CONFIG_IP_NF_ARP_MANGLE=y
 #
 CONFIG_IPV6_SCTP__=y
 # CONFIG_IP_SCTP is not set
+# CONFIG_SCTP_HMAC_NONE is not set
+CONFIG_SCTP_HMAC_SHA1=y
+# CONFIG_SCTP_HMAC_MD5 is not set
 # CONFIG_ATM is not set
 # CONFIG_VLAN_8021Q is not set
 
@@ -292,6 +295,7 @@ CONFIG_NET_SCHED=y
 CONFIG_NET_SCH_CBQ=y
 CONFIG_NET_SCH_HTB=y
 CONFIG_NET_SCH_CSZ=y
+CONFIG_NET_SCH_HFSC=y
 CONFIG_NET_SCH_PRIO=y
 CONFIG_NET_SCH_RED=y
 CONFIG_NET_SCH_SFQ=y
@@ -396,10 +400,10 @@ CONFIG_IDEDMA_PCI_WIP=y
 CONFIG_IDEDMA_AUTO=y
 # CONFIG_IDEDMA_IVB is not set
 # CONFIG_DMA_NONPCI is not set
-CONFIG_BLK_DEV_IDE_MODES=y
 # CONFIG_BLK_DEV_ATARAID is not set
 # CONFIG_BLK_DEV_ATARAID_PDC is not set
 # CONFIG_BLK_DEV_ATARAID_HPT is not set
+# CONFIG_BLK_DEV_ATARAID_MEDLEY is not set
 # CONFIG_BLK_DEV_ATARAID_SII is not set
 
 #
@@ -485,6 +489,7 @@ CONFIG_NET_PCI=y
 # CONFIG_FEALNX is not set
 CONFIG_NATSEMI=y
 # CONFIG_NE2K_PCI is not set
+# CONFIG_FORCEDETH is not set
 # CONFIG_NE3210 is not set
 # CONFIG_ES3210 is not set
 # CONFIG_8139CP is not set
@@ -547,6 +552,7 @@ CONFIG_HOSTAP=m
 CONFIG_PCMCIA_HERMES=m
 CONFIG_HOSTAP_CS=m
 # CONFIG_AIRO_CS is not set
+# CONFIG_PCMCIA_ATMEL is not set
 CONFIG_NET_WIRELESS=y
 
 #
@@ -595,6 +601,7 @@ CONFIG_NET_WIRELESS=y
 # CONFIG_INPUT_MOUSEDEV is not set
 # CONFIG_INPUT_JOYDEV is not set
 # CONFIG_INPUT_EVDEV is not set
+# CONFIG_INPUT_UINPUT is not set
 
 #
 # Character devices
@@ -642,6 +649,7 @@ CONFIG_UNIX98_PTY_COUNT=256
 # Watchdog Cards
 #
 # CONFIG_WATCHDOG is not set
+# CONFIG_SCx200 is not set
 # CONFIG_SCx200_GPIO is not set
 CONFIG_AMD_RNG=y
 # CONFIG_INTEL_RNG is not set
@@ -671,6 +679,7 @@ CONFIG_RTC=y
 # CONFIG_PCMCIA_SERIAL_CS is not set
 # CONFIG_SYNCLINK_CS is not set
 # CONFIG_MWAVE is not set
+# CONFIG_OBMOUSE is not set
 
 #
 # Multimedia devices
@@ -733,6 +742,11 @@ CONFIG_DEVPTS_FS=y
 # CONFIG_UDF_RW is not set
 # CONFIG_UFS_FS is not set
 # CONFIG_UFS_FS_WRITE is not set
+# CONFIG_XFS_FS is not set
+# CONFIG_XFS_QUOTA is not set
+# CONFIG_XFS_RT is not set
+# CONFIG_XFS_TRACE is not set
+# CONFIG_XFS_DEBUG is not set
 
 #
 # Network File Systems