jquery-sidebar: new package
authorYegor Yefremov <yegorslists@googlemail.com>
Wed, 23 Dec 2015 06:34:35 +0000 (07:34 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 23 Dec 2015 08:56:37 +0000 (09:56 +0100)
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/jquery-sidebar/Config.in [new file with mode: 0644]
package/jquery-sidebar/jquery-sidebar.hash [new file with mode: 0644]
package/jquery-sidebar/jquery-sidebar.mk [new file with mode: 0644]

index 4292188e79c16f84ee711154ca85e8ab7534f5fe..de0ad5eaf1dc57ebe5e1113ca030be3d92fb0638 100644 (file)
@@ -953,6 +953,7 @@ menu "external jQuery plugins"
        source "package/jquery-datetimepicker/Config.in"
        source "package/jquery-keyboard/Config.in"
        source "package/jquery-mobile/Config.in"
+       source "package/jquery-sidebar/Config.in"
        source "package/jquery-sparkline/Config.in"
        source "package/jquery-ui/Config.in"
        source "package/jquery-ui-themes/Config.in"
diff --git a/package/jquery-sidebar/Config.in b/package/jquery-sidebar/Config.in
new file mode 100644 (file)
index 0000000..324a20c
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_JQUERY_SIDEBAR
+       bool "jquery-sidebar"
+       help
+         A stupid simple sidebar jQuery plugin.
+
+         http://jillix.github.io/jQuery-sidebar/
diff --git a/package/jquery-sidebar/jquery-sidebar.hash b/package/jquery-sidebar/jquery-sidebar.hash
new file mode 100644 (file)
index 0000000..60e44d4
--- /dev/null
@@ -0,0 +1,2 @@
+# Locally computed
+sha256  c96e46439a87555f2200442f597cce64f21f81f94d7601ddfc3b837913ddb42f  jquery-sidebar-3.3.2.tar.gz
diff --git a/package/jquery-sidebar/jquery-sidebar.mk b/package/jquery-sidebar/jquery-sidebar.mk
new file mode 100644 (file)
index 0000000..7af3667
--- /dev/null
@@ -0,0 +1,17 @@
+################################################################################
+#
+# jquery-sidebar
+#
+################################################################################
+
+JQUERY_SIDEBAR_VERSION = 3.3.2
+JQUERY_SIDEBAR_SITE = $(call github,jillix,jQuery-sidebar,$(JQUERY_SIDEBAR_VERSION))
+JQUERY_SIDEBAR_LICENSE = MIT
+JQUERY_SIDEBAR_LICENSE_FILES = LICENSE
+
+define JQUERY_SIDEBAR_INSTALL_TARGET_CMDS
+       $(INSTALL) -m 0644 -D $(@D)/src/jquery.sidebar.min.js \
+               $(TARGET_DIR)/var/www/jquery-plugins/sidebar/jquery.sidebar.min.js
+endef
+
+$(eval $(generic-package))