sqlite: add option for meta-data about tables/queries
authorPeter Seiderer <ps.report@gmx.net>
Fri, 2 Mar 2018 19:34:35 +0000 (20:34 +0100)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sun, 1 Apr 2018 19:03:50 +0000 (21:03 +0200)
Enables SQLITE_ENABLE_COLUMN_METADATA to gain access to:

  - sqlite3_column_database_name()
  - sqlite3_column_database_name16()
  - sqlite3_column_table_name()
  - sqlite3_column_table_name16()
  - sqlite3_column_origin_name()
  - sqlite3_column_origin_name16()

Signed-off-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/sqlite/Config.in
package/sqlite/sqlite.mk

index ec7396860c2241edcf195dab08238e175b9a8e1d..517af50e679e5563fe9a5ed21103654f2688edc5 100644 (file)
@@ -16,6 +16,13 @@ config BR2_PACKAGE_SQLITE_STAT3
          query planner that can help SQLite to choose a better query
          plan under certain situations.
 
+config BR2_PACKAGE_SQLITE_ENABLE_COLUMN_METADATA
+       bool "Enable convenient access to meta-data about tables and queries"
+       help
+         When this option is defined there are some additional APIs
+         enabled to acces meta-data about tables and queries (see
+         https://sqlite.org/compile.html).
+
 config BR2_PACKAGE_SQLITE_ENABLE_FTS3
        bool "Enable version 3 of the full-text search engine"
        help
index e8ce92df56eba91e9e048d897df6650acfe5b835..d0030d43abe07b15ebbd2f0a316e8c03cd3e1a29 100644 (file)
@@ -15,6 +15,10 @@ ifeq ($(BR2_PACKAGE_SQLITE_STAT3),y)
 SQLITE_CFLAGS += -DSQLITE_ENABLE_STAT3
 endif
 
+ifeq ($(BR2_PACKAGE_SQLITE_ENABLE_COLUMN_METADATA),y)
+SQLITE_CFLAGS += -DSQLITE_ENABLE_COLUMN_METADATA
+endif
+
 ifeq ($(BR2_PACKAGE_SQLITE_ENABLE_FTS3),y)
 SQLITE_CFLAGS += -DSQLITE_ENABLE_FTS3
 endif