package/lvm2: drop BR2_PACKAGE_LVM2_LVMETAD
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 16 May 2021 20:27:22 +0000 (22:27 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Mon, 17 May 2021 07:19:42 +0000 (09:19 +0200)
lvmetad has been dropped since version 2.03.00 and
https://github.com/lvmteam/lvm2/commit/117160b27e510dceb1ed6acf995115c040acd88d

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
Config.in.legacy
package/lvm2/Config.in
package/lvm2/lvm2.mk

index ce6aeed87dff35a391c86403067db19360dfbda3..39a44f302659ff0d7f7b8af678a498ed017acd96 100644 (file)
@@ -146,6 +146,12 @@ endif
 
 comment "Legacy options removed in 2021.05"
 
+config BR2_PACKAGE_LVM2_LVMETAD
+       bool "lvm2 lvmetad removed"
+       select BR2_LEGACY
+       help
+         The lvm2 lvmetad was removed upstream.
+
 config BR2_PACKAGE_MONKEY
        bool "monkey package removed"
        select BR2_LEGACY
index a9c5c453fc04db532cc14f92164362d8539ef62d..de5b972e999f9b3fb8a65fe2a2ad42e20fbcb425 100644 (file)
@@ -47,23 +47,6 @@ config BR2_PACKAGE_LVM2_APP_LIBRARY
 comment "lvm2 application library needs a glibc or uClibc toolchain"
        depends on BR2_TOOLCHAIN_USES_MUSL
 
-config BR2_PACKAGE_LVM2_LVMETAD
-       bool "install lvmetad"
-       depends on !BR2_TOOLCHAIN_USES_MUSL # lvm2-app-library
-       select BR2_PACKAGE_LVM2_APP_LIBRARY
-       help
-         Install lvmetad
-
-         The lvmetad daemon caches LVM metadata so that LVM commands
-         can read metadata from the cache rather than scanning disks.
-         This can be an advantage because scanning disks is time
-         consuming and may interfere with the normal work of the
-         system.  lvmetad can be a disadvantage when disk event
-         notifications from the system are unreliable.
-
-comment "lvmetad daemon needs a glibc or uClibc toolchain"
-       depends on BR2_TOOLCHAIN_USES_MUSL
-
 endif
 
 comment "lvm2 needs a toolchain w/ threads, dynamic library"
index 1194044537f76b788e8b684dd899d687ac23099e..84ec75530a4170859c52cca6dc1c00f08ef3a0b0 100644 (file)
@@ -61,12 +61,6 @@ else
 LVM2_CONF_OPTS += --disable-applib
 endif
 
-ifeq ($(BR2_PACKAGE_LVM2_LVMETAD),y)
-LVM2_CONF_OPTS += --enable-lvmetad
-else
-LVM2_CONF_OPTS += --disable-lvmetad
-endif
-
 ifeq ($(BR2_INIT_SYSTEMD),y)
 LVM2_INSTALL_TARGET_OPTS += install_systemd_units install_systemd_generators
 endif