qdecoder: autoreconf and fix c99 detection
authorPeter Korsgaard <peter@korsgaard.com>
Fri, 9 May 2014 14:22:12 +0000 (16:22 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 9 May 2014 14:23:38 +0000 (16:23 +0200)
Fixes http://autobuild.buildroot.net/results/da8/da8ce760cdabeb9d4cda00dcc801817e4b4eb12c/

As we're patching configure.ac we need to autoreconf the package.
After reconf, the c99 check fails, so force it like we do elsewhere.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/qdecoder/qdecoder.mk

index 506d975a6cb47067cbca15267562769ce9518044..bbbf42a98c22442aef2cfec84d62f99066837457 100644 (file)
@@ -8,6 +8,9 @@ QDECODER_VERSION = r12.0.5
 QDECODER_SITE = $(call github,wolkykim,qdecoder,$(QDECODER_VERSION))
 QDECODER_LICENSE = BSD-2
 QDECODER_LICENSE_FILES = COPYING
+# we patch configure.ac
+QDECODER_AUTORECONF = YES
+QDECODER_CONF_ENV = ac_cv_prog_cc_c99='-std=gnu99'
 
 QDECODER_INSTALL_STAGING = YES