package/python-cssutils: new package
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 9 Oct 2016 12:46:22 +0000 (14:46 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 9 Oct 2016 21:00:49 +0000 (23:00 +0200)
Needed for upcoming python-mwscrape2slob package.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/python-cssutils/Config.in [new file with mode: 0644]
package/python-cssutils/python-cssutils.hash [new file with mode: 0644]
package/python-cssutils/python-cssutils.mk [new file with mode: 0644]

index 6172f0f7219e2f551044ed29eb83e47e3bbef9cf..10381e4e5a3a854b5fc43f3c972859c53bf944f5 100644 (file)
@@ -663,6 +663,7 @@ menu "External python modules"
        source "package/python-crossbar/Config.in"
        source "package/python-cryptography/Config.in"
        source "package/python-cssselect/Config.in"
+       source "package/python-cssutils/Config.in"
        source "package/python-daemon/Config.in"
        source "package/python-dataproperty/Config.in"
        source "package/python-dateutil/Config.in"
diff --git a/package/python-cssutils/Config.in b/package/python-cssutils/Config.in
new file mode 100644 (file)
index 0000000..74de742
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_PYTHON_CSSUTILS
+       bool "python-cssutils"
+       select BR2_PACKAGE_PYTHON_PYEXPAT if BR2_PACKAGE_PYTHON # runtime
+       select BR2_PACKAGE_PYTHON3_PYEXPAT if BR2_PACKAGE_PYTHON3 # runtime
+       help
+         A CSS Cascading Style Sheets library for Python.
+
+         http://cthedot.de/cssutils/
diff --git a/package/python-cssutils/python-cssutils.hash b/package/python-cssutils/python-cssutils.hash
new file mode 100644 (file)
index 0000000..7b188bc
--- /dev/null
@@ -0,0 +1,3 @@
+# md5 from https://pypi.python.org/pypi/cssutils/json, sha256 locally computed
+md5    7fcdf2c3e9f053136af1990146eb361d  cssutils-1.0.1.tar.gz
+sha256 d8a18b2848ea1011750231f1dd64fe9053dbec1be0b37563c582561e7a529063  cssutils-1.0.1.tar.gz
diff --git a/package/python-cssutils/python-cssutils.mk b/package/python-cssutils/python-cssutils.mk
new file mode 100644 (file)
index 0000000..3dd501a
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-cssutils
+#
+################################################################################
+
+PYTHON_CSSUTILS_VERSION = 1.0.1
+PYTHON_CSSUTILS_SOURCE = cssutils-$(PYTHON_CSSUTILS_VERSION).tar.gz
+PYTHON_CSSUTILS_SITE = https://pypi.python.org/packages/22/de/6b03e0088baf0299ab7d2e95a9e26c2092e9cb3855876b958b6a62175ca2
+PYTHON_CSSUTILS_LICENSE = LGPLv3+
+PYTHON_CSSUTILS_LICENSE_FILES = COPYING.LESSER
+PYTHON_CSSUTILS_SETUP_TYPE = setuptools
+
+$(eval $(python-package))