package/luaposix: bump to version 34.1.1
authorFrancois Perrad <fperrad@gmail.com>
Thu, 1 Aug 2019 10:19:10 +0000 (12:19 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 1 Aug 2019 16:11:33 +0000 (18:11 +0200)
the module std.normalize is no longer a dependency

Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/luaposix/Config.in
package/luaposix/luaposix.hash
package/luaposix/luaposix.mk
support/testing/tests/package/test_luaposix.py

index bdc9926b1e84c3f3a96ee92d2b1dcc67bc4137e5..1e2291b3f58bd91fec2e84d829d296c5ebf4585e 100644 (file)
@@ -1,6 +1,5 @@
 config BR2_PACKAGE_LUAPOSIX
        bool "luaposix"
-       select BR2_PACKAGE_LUA_STD_NORMALIZE # runtime
        # "bit32" is included in Lua 5.2+. luajit has an equivalent
        # "bit" module, but since it has a different name, luaposix
        # doesn't find it.
index a6b5cd42d485a2311210ad740c3529c11fd6dfaa..fb06bc40a1ff49e0656b0ea7800e77a2199344a9 100644 (file)
@@ -1,2 +1,2 @@
 # Locally calculated
-sha256 b0f8bdfe4b43b6d79b8f3e8ef5b158de889e5dde046618a33335a38d2b5b90f9  luaposix-34.1.tar.gz
+sha256 7948f4ac8b953172e928753632e37ad97cc3014df74b524fe7839f71216a7e90  luaposix-34.1.1.tar.gz
index c7a954296988a0c39958ce9d01e0a15f1e2a02aa..ab6b030fcaf0196e1a0cf17ae996e829c54ce698 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-LUAPOSIX_VERSION = 34.1
+LUAPOSIX_VERSION = 34.1.1
 LUAPOSIX_SITE = $(call github,luaposix,luaposix,v$(LUAPOSIX_VERSION))
 LUAPOSIX_LICENSE = MIT
 LUAPOSIX_LICENSE_FILES = LICENSE
index 0182faf2f802bcc15bbaff4a37028031ec8a0072..2918ee61b595e19e4988c0666aced40e6abefecf 100644 (file)
@@ -39,6 +39,7 @@ class TestLuaLuaPosix(TestLuaBase):
         self.module_test("posix.time")
         self.module_test("posix.unistd")
         self.module_test("posix.utime")
+        self.module_test("posix")
 
 
 class TestLuajitLuaPosix(TestLuaBase):
@@ -79,3 +80,4 @@ class TestLuajitLuaPosix(TestLuaBase):
         self.module_test("posix.time")
         self.module_test("posix.unistd")
         self.module_test("posix.utime")
+        self.module_test("posix")