python-wcwidth: new package
authorYegor Yefremov <yegorslists@googlemail.com>
Tue, 12 Jul 2016 07:39:02 +0000 (09:39 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 15 Jul 2016 12:40:30 +0000 (14:40 +0200)
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/python-wcwidth/Config.in [new file with mode: 0644]
package/python-wcwidth/python-wcwidth.hash [new file with mode: 0644]
package/python-wcwidth/python-wcwidth.mk [new file with mode: 0644]

index 1910251ddc03a251b02b5e250b6e11bac616cc57..07e7887e6cb3f69950886c76772dac96763c3d9d 100644 (file)
@@ -769,6 +769,7 @@ menu "External python modules"
        source "package/python-urwid/Config.in"
        source "package/python-versiontools/Config.in"
        source "package/python-watchdog/Config.in"
+       source "package/python-wcwidth/Config.in"
        source "package/python-web2py/Config.in"
        source "package/python-webpy/Config.in"
        source "package/python-werkzeug/Config.in"
diff --git a/package/python-wcwidth/Config.in b/package/python-wcwidth/Config.in
new file mode 100644 (file)
index 0000000..c5cc022
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_PYTHON_WCWIDTH
+       bool "python-wcwidth"
+       help
+         This library measures number of Terminal column cells of
+         wide-character codes.
+
+         https://github.com/jquast/wcwidth
diff --git a/package/python-wcwidth/python-wcwidth.hash b/package/python-wcwidth/python-wcwidth.hash
new file mode 100644 (file)
index 0000000..a3ab50f
--- /dev/null
@@ -0,0 +1,3 @@
+# md5 from https://pypi.python.org/pypi/wcwidth/json, sha256 locally computed
+md5    b3b6a0a08f0c8a34d1de8cf44150a4ad        wcwidth-0.1.7.tar.gz
+sha256 3df37372226d6e63e1b1e1eda15c594bca98a22d33a23832a90998faa96bc65e        wcwidth-0.1.7.tar.gz
diff --git a/package/python-wcwidth/python-wcwidth.mk b/package/python-wcwidth/python-wcwidth.mk
new file mode 100644 (file)
index 0000000..2dd392a
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-wcwidth
+#
+################################################################################
+
+PYTHON_WCWIDTH_VERSION = 0.1.7
+PYTHON_WCWIDTH_SOURCE = wcwidth-$(PYTHON_WCWIDTH_VERSION).tar.gz
+PYTHON_WCWIDTH_SITE = https://pypi.python.org/packages/55/11/e4a2bb08bb450fdbd42cc709dd40de4ed2c472cf0ccb9e64af22279c5495
+PYTHON_WCWIDTH_SETUP_TYPE = setuptools
+PYTHON_WCWIDTH_LICENSE = MIT
+PYTHON_WCWIDTH_LICENSE_FILES = LICENSE.txt
+
+$(eval $(python-package))