cmake: bump version to 3.8.2
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>
Fri, 2 Jun 2017 10:16:41 +0000 (11:16 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 6 Jun 2017 20:48:42 +0000 (22:48 +0200)
cmake depends on rhash, but host-cmake doesn't. This is because we use
the bundled dependencies for host-cmake but not for target.

Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/cmake/Config.in
package/cmake/cmake.hash
package/cmake/cmake.mk

index 64ab15418d23259e795dfbbd1bcc7f6e97f6ca95..e7bd14e69a8877f0d5fc526304040f35758e7cd9 100644 (file)
@@ -29,6 +29,7 @@ config BR2_PACKAGE_CMAKE_CTEST
        select BR2_PACKAGE_BZIP2
        select BR2_PACKAGE_XZ
        select BR2_PACKAGE_LIBUV
+       select BR2_PACKAGE_RHASH
        help
          CTest is a testing tool distributed as a part of CMake. It
          can be used to automate updating (using CVS for example),
index 13c02375947928668631d2518156c553bd189bea..f138ac79a1e5114225849c6747df6edd2cf149d5 100644 (file)
@@ -1,2 +1,2 @@
-# From http://www.cmake.org/files/v3.7/cmake-3.7.2-SHA-256.txt
-sha256 dc1246c4e6d168ea4d6e042cfba577c1acd65feea27e56f5ff37df920c30cae0  cmake-3.7.2.tar.gz
+# From http://www.cmake.org/files/v3.8/cmake-3.8.2-SHA-256.txt
+sha256 da3072794eb4c09f2d782fcee043847b99bb4cf8d4573978d9b2024214d6e92d  cmake-3.8.2.tar.gz
index d9eea3285723f96b90c8a54dfb1f2100c533f459..46bd1e4e5f9e2db998484d1fb201a8263953c7b3 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-CMAKE_VERSION_MAJOR = 3.7
+CMAKE_VERSION_MAJOR = 3.8
 CMAKE_VERSION = $(CMAKE_VERSION_MAJOR).2
 CMAKE_SITE = https://cmake.org/files/v$(CMAKE_VERSION_MAJOR)
 CMAKE_LICENSE = BSD-3-Clause
@@ -22,7 +22,7 @@ CMAKE_LICENSE_FILES = Copyright.txt
 #   the system-wide libraries instead of rebuilding and statically
 #   linking with the ones bundled into the CMake sources.
 
-CMAKE_DEPENDENCIES = zlib jsoncpp libcurl libarchive expat bzip2 xz libuv
+CMAKE_DEPENDENCIES = zlib jsoncpp libcurl libarchive expat bzip2 xz libuv rhash
 
 CMAKE_CONF_OPTS = \
        -DKWSYS_LFS_WORKS=TRUE \