qpdf: add missing dependency on jpeg
authorOlivier Schonken <olivier.schonken@gmail.com>
Thu, 19 Oct 2017 08:56:35 +0000 (10:56 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 21 Oct 2017 08:15:17 +0000 (10:15 +0200)
Fixes:

  configure: WARNING: unable to find required header jpeglib.h
  configure: WARNING: unable to find required library jpeg
  configure: error: some required prerequisites were not found

Signed-off-by: Olivier Schonken <olivier.schonken@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/qpdf/Config.in
package/qpdf/qpdf.mk

index e8ab9ba9693fa9c97a5c4cfeb29ce1778ab270c9..0b29b6f8279c3c5ca3fb6ef4523e18952d901fc4 100644 (file)
@@ -3,6 +3,7 @@ config BR2_PACKAGE_QPDF
        depends on BR2_INSTALL_LIBSTDCPP
        select BR2_PACKAGE_PCRE
        select BR2_PACKAGE_ZLIB
+       select BR2_PACKAGE_JPEG
        help
          QPDF is a command-line program that does structural, content-
          preserving transformations on PDF files. It could have been called
index 5b775401a623ef903237030a565ef4910f9b8461..27e4d099789c6611a913e0a06ac5e6628a836edc 100644 (file)
@@ -9,7 +9,7 @@ QPDF_SITE = http://downloads.sourceforge.net/project/qpdf/qpdf/$(QPDF_VERSION)
 QPDF_INSTALL_STAGING = YES
 QPDF_LICENSE = Artistic-2.0
 QPDF_LICENSE_FILES = Artistic-2.0
-QPDF_DEPENDENCIES = pcre zlib
+QPDF_DEPENDENCIES = pcre zlib jpeg
 
 QPDF_CONF_OPTS = --without-random