cbootimage: new package
authorJulian Scheel <julian@jusst.de>
Thu, 17 Mar 2016 15:03:57 +0000 (16:03 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 19 Apr 2016 20:33:08 +0000 (22:33 +0200)
Add package for cbootimage host utility that is able to compile bct
files and generate flashable images out of a bct and an image for
tegra processors.

Signed-off-by: Julian Scheel <julian@jusst.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in.host
package/cbootimage/Config.in.host [new file with mode: 0644]
package/cbootimage/cbootimage.hash [new file with mode: 0644]
package/cbootimage/cbootimage.mk [new file with mode: 0644]

index ccded799e44f88fe84459b539131a9b6ee261e0d..c1d40f4962df78a1b1a449b91c1c13a1be72a491 100644 (file)
@@ -1,6 +1,7 @@
 menu "Host utilities"
 
        source "package/aespipe/Config.in.host"
+       source "package/cbootimage/Config.in.host"
        source "package/checkpolicy/Config.in.host"
        source "package/cramfs/Config.in.host"
        source "package/dfu-util/Config.in.host"
diff --git a/package/cbootimage/Config.in.host b/package/cbootimage/Config.in.host
new file mode 100644 (file)
index 0000000..1913afa
--- /dev/null
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_HOST_CBOOTIMAGE
+       bool "host cbootimage"
+       depends on BR2_arm || BR2_armeb
+       help
+         This project provides a tool which compiles BCT (Boot
+         Configuration Table) images to place into the boot flash of
+         a Tegra-based device.
+
+         https://github.com/NVIDIA/cbootimage
diff --git a/package/cbootimage/cbootimage.hash b/package/cbootimage/cbootimage.hash
new file mode 100644 (file)
index 0000000..96cf172
--- /dev/null
@@ -0,0 +1,2 @@
+# Locally computed
+sha256 373c108d7b6778c62a33e59ad0cd5ea9ebb379319a0c8b4cf469eaa8bec5521b  cbootimage-v1.7.tar.gz
diff --git a/package/cbootimage/cbootimage.mk b/package/cbootimage/cbootimage.mk
new file mode 100644 (file)
index 0000000..20b17dd
--- /dev/null
@@ -0,0 +1,13 @@
+################################################################################
+#
+# cbootimage
+#
+################################################################################
+
+CBOOTIMAGE_VERSION = v1.7
+CBOOTIMAGE_SITE = $(call github,NVIDIA,cbootimage,$(CBOOTIMAGE_VERSION))
+CBOOTIMAGE_LICENSE = GPLv2
+CBOOTIMAGE_LICENSE_FILES = COPYING
+CBOOTIMAGE_AUTORECONF = YES
+
+$(eval $(host-autotools-package))