package/gpsd: add config option for Spectratime iSync and build fix patch
authorZoltan Gyarmati <mr.zoltan.gyarmati@gmail.com>
Sat, 3 Feb 2018 21:40:53 +0000 (22:40 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 4 Feb 2018 22:45:40 +0000 (23:45 +0100)
As in the inital 3.17 version bump patch the iSync config option was not
added, the iSync driver was implicitly enabled in the gpsd config as default,
and due to a bug in the gpsd build setup, this caused several autobuild issues
which are fixed by this. This commit adds both the Buildroot config option and
the gpsd patch which was also sent to and accepted in upstream.

Fixes:
    http://autobuild.buildroot.net/results/555b4bdd1707aa21e6d3014e30b635c96c5efffc
    http://autobuild.buildroot.net/results/cfc14a2c471c63ecc4c95c12b8e00ed7656acfd2
    http://autobuild.buildroot.net/results/2104e15526bd6f467f0d56dee10b5fa46e2c71dd
    http://autobuild.buildroot.net/results/610b3f898b396c1def682b809482408c2c4555bc
    ... and many more.

Signed-off-by: Zoltan Gyarmati <mr.zoltan.gyarmati@gmail.com>
Reviewed-by: Matt Weber <matthew.weber@rockwellcollins.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/gpsd/0002-Fix-isync-build-when-ublox-not-selected-too.patch [new file with mode: 0644]
package/gpsd/Config.in
package/gpsd/gpsd.mk

diff --git a/package/gpsd/0002-Fix-isync-build-when-ublox-not-selected-too.patch b/package/gpsd/0002-Fix-isync-build-when-ublox-not-selected-too.patch
new file mode 100644 (file)
index 0000000..1dfa960
--- /dev/null
@@ -0,0 +1,36 @@
+From 98c8f5f4429ac3bfc09eee235fee08b9aaff8c52 Mon Sep 17 00:00:00 2001
+From: Zoltan Gyarmati <mr.zoltan.gyarmati@gmail.com>
+Date: Tue, 30 Jan 2018 19:58:54 -0800
+Subject: [PATCH] Fix isync build when ublox not selected too.
+
+The isync support uses the ublox driver, but if the ublox support is
+disabled while isync is enabled, the build will fail.
+
+
+Upstream commit:
+http://git.savannah.gnu.org/cgit/gpsd.git/commit/?id=98c8f5f4429ac3bfc09eee235fee08b9aaff8c52
+
+Signed-off-by: Zoltan Gyarmati <mr.zoltan.gyarmati@gmail.com>
+---
+ SConstruct | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/SConstruct b/SConstruct
+index 1c1a215..c6a309e 100644
+--- a/SConstruct
++++ b/SConstruct
+@@ -334,6 +334,11 @@ for driver in ('ashtech',
+         env['nmea0183'] = True
+         break
++
++# iSync uses ublox underneath, so we force to enable it
++if env['isync']:
++    env['ublox'] = True
++
+ opts.Save('.scons-option-cache', env)
+ env.SConsignFile(".sconsign.dblite")
+-- 
+2.7.4
+
index 68d3e2e7e8f8d7d4c0df52cd48e46cf794dc03b8..d9ab7b7dba5b9bf075155251e399b02369cd6621 100644 (file)
@@ -152,6 +152,11 @@ config BR2_PACKAGE_GPSD_GPSCLOCK
        help
          GPSClock support
 
+config BR2_PACKAGE_GPSD_ISYNC
+       bool "iSync"
+       help
+         Spectratime iSync LNRClok/GRCLOK support
+
 config BR2_PACKAGE_GPSD_ITRAX
        bool "iTrax"
        help
index e3fa20c430331dee5a04af49e8abb13a7f65723d..8c8023e81824f06aa0756156348736e11d79e4a5 100644 (file)
@@ -111,6 +111,9 @@ endif
 ifneq ($(BR2_PACKAGE_GPSD_GPSCLOCK),y)
 GPSD_SCONS_OPTS += gpsclock=no
 endif
+ifneq ($(BR2_PACKAGE_GPSD_ISYNC),y)
+GPSD_SCONS_OPTS += isync=no
+endif
 ifneq ($(BR2_PACKAGE_GPSD_ITRAX),y)
 GPSD_SCONS_OPTS += itrax=no
 endif