grep: bump to version 2.7
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Fri, 17 Dec 2010 16:24:10 +0000 (13:24 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 22 Dec 2010 22:08:13 +0000 (23:08 +0100)
[Peter: needs wchar]
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/grep/Config.in
package/grep/grep.mk

index 430616b18359a28f133b846e853417dadac97c82..1b39922fcad217a1f2ac491dd74d4f7036f4ddc7 100644 (file)
@@ -1,8 +1,12 @@
 config BR2_PACKAGE_GREP
        bool "grep"
+       depends on BR2_USE_WCHAR
        select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT_IF_LOCALE
        select BR2_PACKAGE_LIBINTL if BR2_NEEDS_GETTEXT_IF_LOCALE
        help
          The GNU regular expression matcher.
 
          http://www.gnu.org/software/grep/grep.html
+
+comment "grep needs a toolchain with WCHAR support"
+       depends on !BR2_USE_WCHAR
index 5b945d5f2c222b73f289b573b6197e3f2c9f92e0..e323b1de9326997c660e5f5fe84b6048480eaef4 100644 (file)
@@ -3,11 +3,10 @@
 # grep
 #
 #############################################################
-GREP_VERSION:=2.5.3
-GREP_SOURCE:=grep-$(GREP_VERSION).tar.bz2
-GREP_SITE:=$(BR2_GNU_MIRROR)/grep
-GREP_CONF_OPT = --disable-perl-regexp --without-included-regex
 
+GREP_VERSION = 2.7
+GREP_SITE = $(BR2_GNU_MIRROR)/grep
+GREP_CONF_OPT = --disable-perl-regexp --without-included-regex
 GREP_DEPENDENCIES = $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),gettext libintl)
 
 $(eval $(call AUTOTARGETS,package,grep))