Revert "package/x11r7/xcb-proto: remove pkgconf fix"
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 22 Dec 2018 16:26:41 +0000 (17:26 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 22 Dec 2018 16:26:41 +0000 (17:26 +0100)
This reverts commit 598cd3dc55dfd805de0fa7416062ee3c4a063402,
following the modification of the pkg-config behavior to be like it
used to be.

Fixes:

  http://autobuild.buildroot.net/results/41a4e6b9e17adc75b023e89b231a2e00e3484979/

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/x11r7/xcb-proto/xcb-proto.mk

index bf09cb6b076ff7dbfa693f45e772997941c46336..b85dad7f2c79143bbb2bb87ba5b15ae1c78013af 100644 (file)
@@ -15,5 +15,15 @@ XCB_PROTO_INSTALL_STAGING = YES
 XCB_PROTO_DEPENDENCIES = host-python
 HOST_XCB_PROTO_DEPENDENCIES = host-python
 
+# xcbincludedir/pythondir is used by E.G. libxcb at build time to find the
+# xml / python files, so ensure these expand to their full (host) paths
+define XCB_PROTO_FIXUP_PC_FILE
+       $(SED) 's|^\(xcbincludedir=\)|\1$(STAGING_DIR)|' \
+               -e 's|^\(pythondir=\)|\1$(STAGING_DIR)|' \
+               $(STAGING_DIR)/usr/lib/pkgconfig/xcb-proto.pc
+endef
+
+XCB_PROTO_POST_INSTALL_STAGING_HOOKS += XCB_PROTO_FIXUP_PC_FILE
+
 $(eval $(autotools-package))
 $(eval $(host-autotools-package))