linux-tools: use the new gettext logic
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 3 Jul 2017 20:56:08 +0000 (22:56 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 4 Jul 2017 23:28:45 +0000 (01:28 +0200)
This commit switches to use the new gettext logic, which involves:

 - using TARGET_NLS_DEPENDENCIES instead of hand-encoded dependencies
   on gettext/host-gettext

 - using TARGET_NLS_LIBS to force linking against libintl

 - dropping BR2_PACKAGE_GETTEXT selection. The BR2_USE_WCHAR
   dependency was only needed for gettext, so it is no longer needed.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/linux-tools/Config.in
package/linux-tools/linux-tool-cpupower.mk

index db9ed9f19be54c929edff7eabdd5b5684cc65e1a..9d5bf7acc94dd9ddc836788952d3f815cf2963f1 100644 (file)
@@ -8,18 +8,12 @@ config BR2_PACKAGE_LINUX_TOOLS
 config BR2_PACKAGE_LINUX_TOOLS_CPUPOWER
        bool "cpupower"
        depends on !BR2_bfin # pciutils
-       depends on BR2_USE_WCHAR || !BR2_NEEDS_GETTEXT # gettext
        select BR2_PACKAGE_LINUX_TOOLS
        select BR2_PACKAGE_PCIUTILS
-       select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT
        help
          cpupower is a collection of tools to examine and tune power
          saving related features of your processor.
 
-comment "cpupower needs a toolchain w/ wchar"
-       depends on !BR2_bfin
-       depends on !BR2_USE_WCHAR && BR2_NEEDS_GETTEXT
-
 config BR2_PACKAGE_LINUX_TOOLS_GPIO
        bool "gpio"
        select BR2_PACKAGE_LINUX_TOOLS
index 9958cff8059edb876f5d5fe01b184fe9766f0803..2a2d3e01dd5a865bfc88c35736c2b8b8469ff52c 100644 (file)
@@ -6,12 +6,12 @@
 
 LINUX_TOOLS += cpupower
 
-CPUPOWER_DEPENDENCIES = pciutils $(if $(BR2_NEEDS_GETTEXT),gettext)
+CPUPOWER_DEPENDENCIES = pciutils $(TARGET_NLS_DEPENDENCIES)
 
 CPUPOWER_MAKE_OPTS = CROSS=$(TARGET_CROSS) \
        CPUFREQ_BENCH=false \
        NLS=false \
-       $(if $(BR2_NEEDS_GETTEXT),LDFLAGS=-lintl) \
+       LDFLAGS=$(TARGET_NLS_LIBS) \
        DEBUG=false
 
 define CPUPOWER_BUILD_CMDS