rsyslog: Fix systemd service creation
authorMaxime Hadjinlian <maxime.hadjinlian@gmail.com>
Tue, 14 Jul 2015 14:38:20 +0000 (16:38 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 14 Jul 2015 21:58:54 +0000 (23:58 +0200)
The rsyslog.service is installed by rsyslog, but the link is not created
so the service is not enabled.
In order to install the service file, use the correct configure flag.

So the INSTALL_INIT_SYSTEMD will create the link, it will also create
another link which is due to the fact that the rsyslog.service contains
an Alias=

If we were to use systemctl enable to enable the service, it would
create both,so we mimic that.

Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/rsyslog/rsyslog.mk

index 261f59dd35c9b30dea8f4341e267063be256b7cb..1de481f16fb8b6b32fa13e465da65957c3743ffe 100644 (file)
@@ -57,17 +57,32 @@ else
 RSYSLOG_CONF_OPTS += --disable-uuid
 endif
 
+ifeq ($(BR2_INIT_SYSTEMD),y)
+RSYSLOG_CONF_OPTS += \
+       --enable-systemd \
+       --with-systemdsystemunitdir=/usr/lib/systemd/system
+RSYSLOG_DEPENDENCIES += systemd
+else
+RSYSLOG_CONF_OPTS += --disable-systemd
+endif
+
 define RSYSLOG_INSTALL_INIT_SYSV
        $(INSTALL) -m 0755 -D package/rsyslog/S01logging \
                $(TARGET_DIR)/etc/init.d/S01logging
 endef
 
+# The rsyslog.service is installed by rsyslog, but the link is not created
+# so the service is not enabled.
+# We need to create another link which is due to the fact that the
+# rsyslog.service contains an Alias=
+# If we were to use systemctl enable to enable the service, it would
+# create both, so we mimic that.
 define RSYSLOG_INSTALL_INIT_SYSTEMD
-       ln -sf /lib/systemd/system/rsyslog.service \
-               $(TARGET_DIR)/etc/systemd/system/syslog.service
        mkdir -p $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants
-       ln -sf ../syslog.service \
-               $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants/syslog.service
+       ln -sf ../../../../usr/lib/systemd/system/rsyslog.service \
+               $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants/rsyslog.service
+       ln -sf ../../../../usr/lib/systemd/system/rsyslog.service \
+               $(TARGET_DIR)/etc/systemd/system/syslog.service
 endef
 
 define RSYSLOG_INSTALL_CONF