kvm-unit-tests: add patch to remove -Werror
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 6 Nov 2016 12:57:51 +0000 (13:57 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 6 Nov 2016 12:57:51 +0000 (13:57 +0100)
Fixes:

  http://autobuild.buildroot.net/results/52c02c68be6c0b3e907f7ed645bd2d18476ec4f3/

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/kvm-unit-tests/0001-remove-werror.patch [new file with mode: 0644]

diff --git a/package/kvm-unit-tests/0001-remove-werror.patch b/package/kvm-unit-tests/0001-remove-werror.patch
new file mode 100644 (file)
index 0000000..058a640
--- /dev/null
@@ -0,0 +1,17 @@
+Remove -Werror to avoid build failures
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: b/Makefile
+===================================================================
+--- a/Makefile
++++ b/Makefile
+@@ -45,7 +45,7 @@
+               > /dev/null 2>&1; then echo "$(1)"; else echo "$(2)"; fi ;)
+ CFLAGS += -g
+-CFLAGS += $(autodepend-flags) -Wall -Werror -Wno-frame-address
++CFLAGS += $(autodepend-flags) -Wall -Wno-frame-address
+ frame-pointer-flag=-f$(if $(KEEP_FRAME_POINTER),no-,)omit-frame-pointer
+ fomit_frame_pointer := $(call cc-option, $(frame-pointer-flag), "")
+ fnostack_protector := $(call cc-option, -fno-stack-protector, "")