toolchain/helpers: don't use the x$(...) = x"value" syntax
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 17 Jul 2013 20:30:47 +0000 (22:30 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 17 Jul 2013 20:51:04 +0000 (22:51 +0200)
As noted by Yann E. Morin, the x$(...) = x"value" syntax is old and
ugly, and the easier to read "$(...)" = "value" can now be used
without problems.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
toolchain/helpers.mk

index 95217e7b29c57488dbb16d629c882af413b305eb..764c795d85ce311570f30fe4d7ad3b8f0bf1a330 100644 (file)
@@ -181,7 +181,7 @@ create_lib64_symlinks = \
 # $2: feature description
 #
 check_glibc_feature = \
-       if [ x$($(1)) != x"y" ] ; then \
+       if [ "$($(1))" != "y" ] ; then \
                echo "$(2) available in C library, please enable $(1)" ; \
                exit 1 ; \
        fi
@@ -236,11 +236,11 @@ check_glibc = \
 #
 check_uclibc_feature = \
        IS_IN_LIBC=`grep -q "\#define $(1) 1" $(3) && echo y` ; \
-       if [ x$($(2)) != x"y" -a x$${IS_IN_LIBC} = x"y" ] ; then \
+       if [ "$($(2))" != "y" -a "$${IS_IN_LIBC}" = "y" ] ; then \
                echo "$(4) available in C library, please enable $(2)" ; \
                exit 1 ; \
        fi ; \
-       if [ x$($(2)) = x"y" -a x$${IS_IN_LIBC} != x"y" ] ; then \
+       if [ "$($(2))" = "y" -a "$${IS_IN_LIBC}" != "y" ] ; then \
                echo "$(4) not available in C library, please disable $(2)" ; \
                exit 1 ; \
        fi