e2fsprogs: disable e4defrag in host variant
authorHollis Blanchard <hollis_blanchard@mentor.com>
Wed, 29 Jul 2015 18:47:38 +0000 (11:47 -0700)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 29 Jul 2015 20:20:52 +0000 (22:20 +0200)
e4defrag from e2fsprogs 1.42.13 encounters these build errors on RHEL5.8 hosts:
e4defrag.c:197:2: error: #error sync_file_range not available!
e4defrag.c:201:2: error: #error fallocate64 not available!

It's possible to fix these problems, but we don't use it on the host
anyway, so just disable it.

Signed-off-by: Hollis Blanchard <hollis_blanchard@mentor.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/e2fsprogs/e2fsprogs.mk

index c863f702ce6a5eb6fc8ad90326468d1fe2b27680..178372b2a6820e47c27769131568e926e0eec4a0 100644 (file)
@@ -12,6 +12,10 @@ E2FSPROGS_LICENSE_FILES = COPYING lib/uuid/COPYING lib/ss/mit-sipb-copyright.h l
 E2FSPROGS_INSTALL_STAGING = YES
 E2FSPROGS_INSTALL_STAGING_OPTS = DESTDIR=$(STAGING_DIR) install-libs
 
+# e4defrag doesn't build on older systems like RHEL5.x, and we don't
+# need it on the host anyway.
+HOST_E2FSPROGS_CONF_OPTS += --disable-defrag
+
 E2FSPROGS_CONF_OPTS = \
        $(if $(BR2_STATIC_LIBS),,--enable-elf-shlibs) \
        $(if $(BR2_PACKAGE_E2FSPROGS_DEBUGFS),,--disable-debugfs) \