attr: add host variant
authorGustavo Zacarias <gustavo.zacarias@free-electrons.com>
Wed, 24 Feb 2016 14:26:29 +0000 (11:26 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 25 Feb 2016 21:24:14 +0000 (22:24 +0100)
This is required for host-libcap for extended attributes support, which
leads to capabilities support as well.

Signed-off-by: Gustavo Zacarias <gustavo.zacarias@free-electrons.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/attr/attr.mk

index a66891b85739c72d210e17d4c51aee29ceacdf40..e9963bac8e3a9b5d882072ec7b67bc89e6cd09ec 100644 (file)
@@ -26,6 +26,11 @@ ATTR_INSTALL_TARGET_OPTS =                   \
        exec_prefix=$(TARGET_DIR)/usr           \
        install install-lib
 
+HOST_ATTR_INSTALL_OPTS = \
+       prefix=$(HOST_DIR)/usr \
+       exec_prefix=$(HOST_DIR)/usr \
+       install-dev install-lib
+
 # The libdir variable in libattr.la is empty, so let's fix it. This is
 # probably due to attr not using automake, and not doing fully the
 # right thing with libtool.
@@ -37,3 +42,4 @@ endef
 ATTR_POST_INSTALL_STAGING_HOOKS += ATTR_FIX_LIBTOOL_LA_LIBDIR
 
 $(eval $(autotools-package))
+$(eval $(host-autotools-package))