projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
8bda3c5
)
package/sudo: add optional support for zlib
author
Bernd Kuhls
<bernd.kuhls@t-online.de>
Sat, 5 Nov 2016 15:57:52 +0000
(16:57 +0100)
committer
Thomas Petazzoni
<thomas.petazzoni@free-electrons.com>
Sat, 5 Nov 2016 22:31:55 +0000
(23:31 +0100)
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/sudo/sudo.mk
patch
|
blob
|
history
diff --git
a/package/sudo/sudo.mk
b/package/sudo/sudo.mk
index f28312ace1a2ba9b468abf59339d4057e56264a4..89859dda035c8f8b05bf34eb4c58dd27d86e4967 100644
(file)
--- a/
package/sudo/sudo.mk
+++ b/
package/sudo/sudo.mk
@@
-30,6
+30,13
@@
else
SUDO_CONF_OPTS += --without-pam
endif
+ifeq ($(BR2_PACKAGE_ZLIB),y)
+SUDO_CONF_OPTS += --enable-zlib
+SUDO_DEPENDENCIES += zlib
+else
+SUDO_CONF_OPTS += --disable-zlib
+endif
+
# mksigname/mksiglist needs to run on build host to generate source files
define SUDO_BUILD_MKSIGNAME_MKSIGLIST_HOST
$(MAKE) $(HOST_CONFIGURE_OPTS) \