faifa: new package
authorMaxime Hadjinlian <maxime.hadjinlian@gmail.com>
Wed, 28 May 2014 13:39:06 +0000 (15:39 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 8 Jun 2014 16:30:58 +0000 (18:30 +0200)
faifa is a library and a cli used to manage PLC hardware that use
Intellon chipset.  Almost everybody use theses chips nowadays.

[Thomas: license is GPLv2+, not GPLv2. Fix indentation. Add dependency
on host-autoconf and a comment to explain what's going on. Fix
indentation of target/staging installation commands. Mark the package
as not available for static library builds as it always build a shared
library. Rewrap Config.in help text.]

Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/faifa/Config.in [new file with mode: 0644]
package/faifa/faifa.mk [new file with mode: 0644]

index 763f14881142ff414ba69c8acbd07bba326411a0..d73eaed35f57772cba5b292bcfcb05791a75ae36 100644 (file)
@@ -916,6 +916,7 @@ source "package/dnsmasq/Config.in"
 source "package/dropbear/Config.in"
 source "package/ebtables/Config.in"
 source "package/ethtool/Config.in"
+source "package/faifa/Config.in"
 source "package/foomatic-filters/Config.in"
 source "package/fping/Config.in"
 source "package/gesftpserver/Config.in"
diff --git a/package/faifa/Config.in b/package/faifa/Config.in
new file mode 100644 (file)
index 0000000..2acd505
--- /dev/null
@@ -0,0 +1,15 @@
+config BR2_PACKAGE_FAIFA
+       bool "faifa"
+       select BR2_PACKAGE_LIBPCAP
+       depends on !BR2_PREFER_STATIC_LIB
+       help
+         Faifa can configure any Intellon-based Power Line
+         Communication device using Intellon INT5000 and INT6000
+         series chips (6000 and 6300 chips). It supports all
+         Intellon-specific management and control frames as well as
+         standard management frames.
+
+         https://dev.open-plc.org
+
+comment "faifa needs a toolchain w/ dynamic library"
+       depends on BR2_PREFER_STATIC_LIB
diff --git a/package/faifa/faifa.mk b/package/faifa/faifa.mk
new file mode 100644 (file)
index 0000000..8f5d258
--- /dev/null
@@ -0,0 +1,39 @@
+################################################################################
+#
+# faifa
+#
+################################################################################
+
+FAIFA_VERSION = aa0b5f90b89a9fd1533137b68ebf85f5437aba53
+FAIFA_SITE = $(call github,ffainelli,faifa,$(FAIFA_VERSION))
+FAIFA_INSTALL_STAGING = YES
+FAIFA_DEPENDENCIES = libpcap host-autoconf
+FAIFA_LICENSE = GPLv2+
+FAIFA_LICENSE_FILES = COPYING
+
+# This package uses autoconf, but not automake, so we need to call
+# their special autogen.sh script, and have custom target and staging
+# installation commands.
+
+define FAIFA_RUN_AUTOGEN
+       cd $(@D) && PATH=$(BR_PATH) ./autogen.sh
+endef
+FAIFA_PRE_CONFIGURE_HOOKS += FAIFA_RUN_AUTOGEN
+
+define FAIFA_INSTALL_TARGET_CMDS
+       $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) \
+               PREFIX=/usr \
+               STRIP=/bin/true \
+               DESTDIR=$(TARGET_DIR) \
+               install
+endef
+
+define FAIFA_INSTALL_STAGING_CMDS
+       $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) \
+               PREFIX=/usr \
+               STRIP=/bin/true \
+               DESTDIR=$(STAGING_DIR) \
+               install
+endef
+
+$(eval $(autotools-package))