replace references to Busybox with BusyBox
authorSimon Dawson <spdawson@gmail.com>
Sat, 31 May 2014 07:55:35 +0000 (08:55 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 1 Jun 2014 21:58:43 +0000 (23:58 +0200)
The correct capitalised form appears to be "BusyBox" rather than "Busybox";
fix all references to the latter form. (Most such references occur in the
manual and in commentary in package makefiles.)

Signed-off-by: Simon Dawson <spdawson@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
18 files changed:
Makefile
docs/manual/common-usage.txt
docs/manual/configure.txt
docs/manual/customize-busybox-config.txt
docs/manual/customize-store.txt
docs/manual/using-buildroot-development.txt
docs/manual/using.txt
package/busybox/1.21.1/0001-libbb-use-poll.h-instead-of-sys-poll.h.patch
package/busybox/busybox.mk
package/coreutils/Config.in
package/openvpn/openvpn.mk
package/pkg-utils.mk
package/rsyslog/rsyslog.mk
package/sysklogd/sysklogd.mk
package/sysvinit/inittab
package/sysvinit/sysvinit.mk
package/xbmc/br-xbmc
system/Config.in

index 9dc24d74520402b79ef418ad2dcd35a0f661f66e..0b4264a5d5a09741b074c821891b7e0c918c3f5f 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -89,7 +89,7 @@ CONFIG_DIR := $(TOPDIR)
 NEED_WRAPPER =
 else
 # other packages might also support Linux-style out of tree builds
-# with the O=<dir> syntax (E.G. Busybox does). As make automatically
+# with the O=<dir> syntax (E.G. BusyBox does). As make automatically
 # forwards command line variable definitions those packages get very
 # confused. Fix this by telling make to not do so
 MAKEOVERRIDES =
index 772982af5cc67666a783a92ad6b1dad658829ff4..16a13512c283c86ead3234f1f0aa622885993b9b 100644 (file)
@@ -76,9 +76,9 @@ to +make+ or set in the environment:
   is the recommended way of setting it.
   +
 * +BUSYBOX_CONFIG_FILE=<path/to/.config>+, path to
-  the Busybox configuration file.
+  the BusyBox configuration file.
   +
-  Note that the Busybox configuration file can also be set from the
+  Note that the BusyBox configuration file can also be set from the
   configuration interface, so through the Buildroot +.config+ file; this
   is the recommended way of setting it.
   +
index eb8cb1d7e0dd0f7fd72faecc488a3b09cf037f86..16b9cd6f2d5b8e9a79b073677b891242dee647c1 100644 (file)
@@ -272,7 +272,7 @@ different solutions to handle the +/dev+ directory :
    requirement to have +CONFIG_DEVTMPFS+ and +CONFIG_DEVTMPFS_MOUNT+
    enabled in the kernel configuration still apply), but adds the
    +mdev+ userspace utility on top of it. +mdev+ is a program part of
-   Busybox that the kernel will call every time a device is added or
+   BusyBox that the kernel will call every time a device is added or
    removed. Thanks to the +/etc/mdev.conf+ configuration file, +mdev+
    can be configured to for example, set specific permissions or
    ownership on a device file, call a script or application whenever a
@@ -314,16 +314,16 @@ graphical applications, other network servers, etc.).
 Buildroot allows to use three different types of init systems, which
 can be chosen from +System configuration+, +Init system+:
 
- * The first solution is *Busybox*. Amongst many programs, Busybox has
+ * The first solution is *BusyBox*. Amongst many programs, BusyBox has
    an implementation of a basic +init+ program, which is sufficient
    for most embedded systems. Enabling the +BR2_INIT_BUSYBOX+ will
-   ensure Busybox will build and install its +init+ program. This is
-   the default solution in Buildroot. The Busybox +init+ program will
+   ensure BusyBox will build and install its +init+ program. This is
+   the default solution in Buildroot. The BusyBox +init+ program will
    read the +/etc/inittab+ file at boot to know what to do. The syntax
    of this file can be found in
    http://git.busybox.net/busybox/tree/examples/inittab (note that
-   Busybox +inittab+ syntax is special: do not use a random +inittab+
-   documentation from the Internet to learn about Busybox
+   BusyBox +inittab+ syntax is special: do not use a random +inittab+
+   documentation from the Internet to learn about BusyBox
    +inittab+). The default +inittab+ in Buildroot is stored in
    +system/skeleton/etc/inittab+. Apart from mounting a few important
    filesystems, the main job the default inittab does is to start the
@@ -336,7 +336,7 @@ can be chosen from +System configuration+, +Init system+:
    Linux distributions, until they switched to more recent
    alternatives such as Upstart or Systemd. +sysvinit+ also works with
    an +inittab+ file (which has a slightly different syntax than the
-   one from Busybox). The default +inittab+ installed with this init
+   one from BusyBox). The default +inittab+ installed with this init
    solution is located in +package/sysvinit/inittab+.
 
  * The third solution is *systemd*. +systemd+ is the new generation
@@ -353,5 +353,5 @@ can be chosen from +System configuration+, +Init system+:
    http://www.freedesktop.org/wiki/Software/systemd.
 
 The solution recommended by Buildroot developers is to use the
-*Busybox init* as it is sufficient for most embedded
+*BusyBox init* as it is sufficient for most embedded
 systems. *systemd* can be used for more complex situations.
index ca1613d9ee42d35c58ab7a824e5c4a2dc1a9de07..a4a85fa55fcea3383fe5a15d0b4bf68fe0765393 100644 (file)
@@ -2,9 +2,9 @@
 // vim: set syntax=asciidoc:
 
 [[busybox-custom]]
-=== Customizing the Busybox configuration
+=== Customizing the BusyBox configuration
 
-http://www.busybox.net/[Busybox] is very configurable, and you may
+http://www.busybox.net/[BusyBox] is very configurable, and you may
 want to customize it. You can follow these simple steps to do so. This
 method isn't optimal, but it's simple, and it works:
 
index 6db8ec78128519d9242b49fcd2ad20688016d07d..e51edb2660b21d29f043f720fe71af74dff7e6b5 100644 (file)
@@ -80,9 +80,9 @@ work.
 
 To do so, you need to create a normal Buildroot configuration that
 builds a basic system for the hardware: toolchain, kernel, bootloader,
-filesystem and a simple Busybox-only userspace. No specific package
+filesystem and a simple BusyBox-only userspace. No specific package
 should be selected: the configuration should be as minimal as
-possible, and should only build a working basic Busybox system for the
+possible, and should only build a working basic BusyBox system for the
 target platform. You can of course use more complicated configurations
 for your internal projects, but the Buildroot project will only
 integrate basic board configurations. This is because package
index 2ecff352504e90b7f33acb980a5a049921254de0..e660e65e5f8c04d5fdbb6c0a03297460aa7dccaf 100644 (file)
@@ -72,7 +72,7 @@ make linux-rebuild all
 -----------------------
 
 and in a matter of seconds gets the updated Linux kernel image in
-+output/images+. Similarly, a change can be made to the Busybox source
++output/images+. Similarly, a change can be made to the BusyBox source
 code in +/home/bob/busybox+, and after:
 
 -----------------------
@@ -80,4 +80,4 @@ make busybox-rebuild all
 -----------------------
 
 the root filesystem image in +output/images+ contains the updated
-Busybox.
+BusyBox.
index 3cd149936a9f9110a83b092d6ccef05be77fe317..292349d12de4c67c45f5ae473829fa0738924f58 100644 (file)
@@ -5,7 +5,7 @@
 
 Buildroot has a nice configuration tool similar to the one you can
 find in the http://www.kernel.org/[Linux kernel] or in
-http://www.busybox.net/[Busybox]. Note that you can *and should build
+http://www.busybox.net/[BusyBox]. Note that you can *and should build
 everything as a normal user*. There is no need to be root to configure
 and use Buildroot. The first step is to run the configuration
 assistant:
index 089d85817ea776516e91811a283ea53851f04afe..0a39d56223a14602fa96666ad1bcdc5d22d7e3bf 100644 (file)
@@ -5,7 +5,7 @@ Subject: [PATCH 1/3] libbb: use <poll.h> instead of <sys/poll.h>
 
 As the pol() manpage recommends, include the <poll.h> header instead
 of <sys/poll.h>. This allows to get rid of gazillions of warnings when
-building Busybox against the musl C library, which prints a warning
+building BusyBox against the musl C library, which prints a warning
 when the internal header <sys/poll.h> is included directly instead of
 the <poll.h> header.
 
index 150100b9786b7e5d7dcbc7d12facd64edd533a81..af1d13f7ecb1f17bcfef99969cdc8c9dd06160e3 100644 (file)
@@ -22,7 +22,7 @@ BUSYBOX_LDFLAGS = \
        $(TARGET_LDFLAGS)
 
 # Link against libtirpc if available so that we can leverage its RPC
-# support for NFS mounting with Busybox
+# support for NFS mounting with BusyBox
 ifeq ($(BR2_PACKAGE_LIBTIRPC),y)
 BUSYBOX_DEPENDENCIES += libtirpc
 BUSYBOX_CFLAGS += -I$(STAGING_DIR)/usr/include/tirpc/
index 152ad14c22178a90cfae1d55f920b62a9806fe59..eee041d6331aee7fb73f441b997d6ad30ec7c52d 100644 (file)
@@ -5,7 +5,7 @@ config BR2_PACKAGE_COREUTILS
        help
          All of the basic file/text/shell utilities.  These are the
          core utilities which are expected to exist on every system.
-         Busybox implements many of the most common.
+         BusyBox implements many of the most common.
 
          Things like:
          - chmod, cp, dd, dir, ls, etc...
index 0355678fb07b88dff815bb12c8ad8be722a9b25c..3cb78a50228e948e2b2278199eef257018a79bc0 100644 (file)
@@ -20,7 +20,7 @@ OPENVPN_CONF_OPT += --enable-small --disable-plugins \
        --disable-debug --disable-eurephia
 endif
 
-# Busybox 1.21+ places the ip applet in the "correct" place
+# BusyBox 1.21+ places the ip applet in the "correct" place
 # but previous versions didn't.
 ifeq ($(BR2_PACKAGE_IPROUTE2),y)
 OPENVPN_CONF_ENV += IPROUTE=/sbin/ip
index c627a6485e07a5e77bbfa9cd0e4343d0906c3157..163ef8a07c4a0fc46f9b4d6f4511acf62afe339c 100644 (file)
@@ -29,7 +29,7 @@ $(eval $(call caseconvert-helper,LOWERCASE,$(join $(addsuffix :,$([TO])),$([FROM
 
 #
 # Manipulation of .config files based on the Kconfig
-# infrastructure. Used by the Busybox package, the Linux kernel
+# infrastructure. Used by the BusyBox package, the Linux kernel
 # package, and more.
 #
 
index 88747b752bba1e1b71a5b0663954c92d60d4dbdb..240f04eaa467b9c07f38c0ce0924f7edcd61d7b6 100644 (file)
@@ -14,7 +14,7 @@ RSYSLOG_AUTORECONF = YES
 RSYSLOG_CONF_OPT = --disable-testbench \
                   --enable-cached-man-pages
 
-# Build after Busybox
+# Build after BusyBox
 ifeq ($(BR2_PACKAGE_BUSYBOX),y)
        RSYSLOG_DEPENDENCIES += busybox
 endif
index c0aaf349155c619b568f67e6d4083508f0577806..886e471d3e30e822fda225a6f4f63104e9f03976 100644 (file)
@@ -9,7 +9,7 @@ SYSKLOGD_SOURCE  = sysklogd_$(SYSKLOGD_VERSION).orig.tar.gz
 SYSKLOGD_PATCH   = sysklogd_$(SYSKLOGD_VERSION)-6.diff.gz
 SYSKLOGD_SITE    = $(BR2_DEBIAN_MIRROR)/debian/pool/main/s/sysklogd
 
-# Override Busybox implementations if Busybox is enabled.
+# Override BusyBox implementations if BusyBox is enabled.
 ifeq ($(BR2_PACKAGE_BUSYBOX),y)
 SYSKLOGD_DEPENDENCIES = busybox
 endif
index c85e75a045ce559aa5eb0dd489019375cb992a02..8812cca29788d54b8d74aa7cf470ce50c59e12bd 100644 (file)
@@ -1,7 +1,7 @@
 # /etc/inittab
 #
 # This inittab is a basic inittab sample for sysvinit, which mimics
-# Buildroot's default inittab for Busybox.
+# Buildroot's default inittab for BusyBox.
 id:1:initdefault:
 
 proc::sysinit:/bin/mount -t proc proc /proc
index 5d4f4bca7cc81abde98448beed5023a10cd20379..371624356bc818d9308fd0d42f8844a102635650 100644 (file)
@@ -11,7 +11,7 @@ SYSVINIT_SITE    = $(BR2_DEBIAN_MIRROR)/debian/pool/main/s/sysvinit
 SYSVINIT_LICENSE = GPLv2+
 SYSVINIT_LICENSE_FILES = COPYING
 
-# Override Busybox implementations if Busybox is enabled.
+# Override BusyBox implementations if BusyBox is enabled.
 ifeq ($(BR2_PACKAGE_BUSYBOX),y)
 SYSVINIT_DEPENDENCIES = busybox
 endif
@@ -34,7 +34,7 @@ define SYSVINIT_INSTALL_TARGET_CMDS
        for x in halt init shutdown killall5; do \
                install -D -m 0755 $(@D)/src/$$x $(TARGET_DIR)/sbin/$$x || exit 1; \
        done
-       # Override Busybox's inittab with an inittab compatible with
+       # Override BusyBox's inittab with an inittab compatible with
        # sysvinit
        install -D -m 0644 package/sysvinit/inittab $(TARGET_DIR)/etc/inittab
        ln -sf /sbin/halt $(TARGET_DIR)/sbin/reboot
index 2a62b31bb6d64c6956baf1a6266bf35344edd78a..922b5111b986784384c4008bfe2b328150c96267 100755 (executable)
@@ -15,10 +15,10 @@ trap trap_kill INT QUIT TERM
 
 LOOP=1
 while [ ${LOOP} -eq 1 ]; do
-    # Hack: Busybox ash does not catch signals while a non-builtin
+    # Hack: BusyBox ash does not catch signals while a non-builtin
     # is running, and only catches the signal when the non-builtin
     # command ends. So, we just background the XBMC binary, and wait
-    # for it. But Busybox' ash's wait builtin does not return the
+    # for it. But BusyBox' ash's wait builtin does not return the
     # exit code even if there was only one job (which is correct
     # for POSIX). So we explicitly wait for the XBMC job
     "${XBMC}" "${@}" &
index a3d80bffdaceee02f11cb9be967beffc85650bc6..53bca536c682b16c37e98a402c680b8a5b0c1780 100644 (file)
@@ -77,7 +77,7 @@ choice
        default BR2_INIT_BUSYBOX
 
 config BR2_INIT_BUSYBOX
-       bool "Busybox"
+       bool "BusyBox"
        select BR2_PACKAGE_BUSYBOX
 
 config BR2_INIT_SYSV