luarocks-package: use $(HOST_PKG_VERSION) instead of $(PKG_VERSION)
authorArnout Vandecappelle <arnout@mind.be>
Thu, 23 Feb 2017 17:00:25 +0000 (18:00 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 2 Mar 2017 21:39:30 +0000 (22:39 +0100)
The inner-luarocks-package macro was using $(3)_VERSION as the package
version, i.e. the version of the target package, even when it's the
host package. We should instead use $(2)_VERSION, i.e. the host package
version, like is done in inner-generic-package.

Since luarocks-package doesn't even support a host version, it doens't
make a whole lot of difference, but let's keep things consistent.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/pkg-luarocks.mk

index da5c912c8138e8599ee5cc5853e4a86a6f8247cc..aa83e74a0e9a455f9b43fa3c4dc368a7687d3abf 100644 (file)
@@ -34,9 +34,9 @@
 define inner-luarocks-package
 
 $(2)_BUILD_OPTS                ?=
-$(2)_SUBDIR            ?= $(1)-$$(shell echo "$$($(3)_VERSION)" | sed -e "s/-[0-9]$$$$//")
-$(2)_ROCKSPEC          ?= $(1)-$$($(3)_VERSION).rockspec
-$(2)_SOURCE            ?= $(1)-$$($(3)_VERSION).src.rock
+$(2)_SUBDIR            ?= $(1)-$$(shell echo "$$($(2)_VERSION)" | sed -e "s/-[0-9]$$$$//")
+$(2)_ROCKSPEC          ?= $(1)-$$($(2)_VERSION).rockspec
+$(2)_SOURCE            ?= $(1)-$$($(2)_VERSION).src.rock
 $(2)_SITE              ?= $$(call qstrip,$$(BR2_LUAROCKS_MIRROR))
 
 # Since we do not support host-luarocks-package, we know this is