package/edid-decode: fix build with gcc <= 5
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 6 Jun 2020 12:28:10 +0000 (14:28 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 6 Jun 2020 19:31:20 +0000 (21:31 +0200)
Pass -std=c++11 to fix the following build failure with gcc <= 5:

/tmp/instance-0/output-1/host/bin/mips64el-linux-g++ -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64  -Os       -Wall -Wextra -Wno-missing-field-initializers -Wno-unused-parameter -g -DSHA="not available" -o edid-decode edid-decode.cpp parse-base-block.cpp parse-cta-block.cpp parse-displayid-block.cpp parse-ls-ext-block.cpp parse-di-ext-block.cpp parse-vtb-ext-block.cpp -lm
edid-decode.cpp: In member function 'std::__cxx11::string edid_state::dtd_type()':
edid-decode.cpp:192:17: error: 'to_string' is not a member of 'std'
  unsigned len = std::to_string(preparse_total_dtds).length();
                 ^

Also add a dependency on gcc 4.7

Fixes:
 - http://autobuild.buildroot.org/results/71e4a50542c4551797f1d0404d27244612b427d7

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/edid-decode/Config.in
package/edid-decode/edid-decode.mk

index d2d21288de84053f5f1819d9b7a3fdc4d5ffc6c3..ddf1942c68a959aeb61d7dbfab07e33324dee7a7 100644 (file)
@@ -1,10 +1,12 @@
 config BR2_PACKAGE_EDID_DECODE
        bool "edid-decode"
        depends on BR2_INSTALL_LIBSTDCPP
+       depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_7 # C++11
        help
          Decode EDID data in human-readable format.
 
          https://git.linuxtv.org/edid-decode.git/
 
-comment "edid-decode needs a toolchain w/ C++"
-       depends on !!BR2_INSTALL_LIBSTDCPP
+comment "edid-decode needs a toolchain w/ C++, gcc >= 4.7"
+       depends on !!BR2_INSTALL_LIBSTDCPP || \
+               !BR2_TOOLCHAIN_GCC_AT_LEAST_4_7
index c41a9f2a76047c1ba3c09e82a8ed9500b47f59e9..7e463c02b1f4842476934ae5d9c354015f5e1f91 100644 (file)
@@ -11,7 +11,7 @@ EDID_DECODE_LICENSE_FILES = LICENSE
 
 define EDID_DECODE_BUILD_CMDS
        $(TARGET_MAKE_ENV) $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) \
-               CFLAGS="$(TARGET_CXXFLAGS)"
+               CFLAGS="$(TARGET_CXXFLAGS) -std=c++11"
 endef
 
 define EDID_DECODE_INSTALL_TARGET_CMDS