imx-codec: add missing configure options
authorGary Bisson <gary.bisson@boundarydevices.com>
Wed, 27 Jul 2016 13:53:31 +0000 (15:53 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 3 Aug 2016 19:59:09 +0000 (21:59 +0200)
Enable VPU and hard float support when the configuration contains:
BR2_ARM_EABIHF=y
BR2_PACKAGE_IMX_VPU=y

See Yocto equivalent:
https://github.com/Freescale/meta-fsl-arm/blob/krogoth/recipes-multimedia/imx-codec/imx-codec.inc

Signed-off-by: Gary Bisson <gary.bisson@boundarydevices.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/freescale-imx/imx-codec/imx-codec.mk

index 2577cf86be7d37d4000c38bda8d2f26722a6fdd0..48408728a481c23c9751267943f7959495a39a50 100644 (file)
@@ -13,6 +13,14 @@ IMX_CODEC_LICENSE = NXP Semiconductor Software License Agreement, BSD-3c (flac,
 IMX_CODEC_LICENSE_FILES = EULA COPYING
 IMX_CODEC_REDISTRIBUTE = NO
 
+ifeq ($(BR2_ARM_EABIHF),y)
+IMX_CODEC_CONF_OPTS += --enable-fhw
+endif
+
+ifeq ($(BR2_PACKAGE_IMX_VPU),y)
+IMX_CODEC_CONF_OPTS += --enable-vpu
+endif
+
 define IMX_CODEC_EXTRACT_CMDS
        $(call FREESCALE_IMX_EXTRACT_HELPER,$(DL_DIR)/$(IMX_CODEC_SOURCE))
 endef