ell: new package
authorPeter Seiderer <ps.report@gmx.net>
Mon, 5 Nov 2018 22:04:25 +0000 (23:04 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 8 Nov 2018 20:39:57 +0000 (21:39 +0100)
Signed-off-by: Peter Seiderer <ps.report@gmx.net>
[Thomas: fix Config.in comment dependencies, add DEVELOPERS entry.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/ell/0001-ell-signal.h-use-standard-sigset_t-fixes-musl-compil.patch [new file with mode: 0644]
package/ell/Config.in [new file with mode: 0644]
package/ell/ell.hash [new file with mode: 0644]
package/ell/ell.mk [new file with mode: 0644]

index 5dca21e72b047200450c1653b202ecd983a5860a..53467da489f8e2f38bb19b2eba74d1e2635f6b1e 100644 (file)
@@ -1655,6 +1655,7 @@ F:        package/ddrescue/
 F:     package/dejavu/
 F:     package/dillo/
 F:     package/edid-decode/
+F:     package/ell/
 F:     package/ghostscript-fonts/
 F:     package/gstreamer1/gst1-interpipe/
 F:     package/gstreamer1/gst1-validate/
index 712e3604020b91d6c686c5667a1bef010474e3f1..b60e7700ada47d49debeadda63628561ecd9ac80 100644 (file)
@@ -1608,6 +1608,7 @@ menu "Other"
        source "package/ding-libs/Config.in"
        source "package/eigen/Config.in"
        source "package/elfutils/Config.in"
+       source "package/ell/Config.in"
        source "package/fftw/Config.in"
        source "package/flann/Config.in"
        source "package/flatbuffers/Config.in"
diff --git a/package/ell/0001-ell-signal.h-use-standard-sigset_t-fixes-musl-compil.patch b/package/ell/0001-ell-signal.h-use-standard-sigset_t-fixes-musl-compil.patch
new file mode 100644 (file)
index 0000000..a1d252b
--- /dev/null
@@ -0,0 +1,57 @@
+From abff9db9a6e86e00613a420dd6a0ba3bc81e2b72 Mon Sep 17 00:00:00 2001
+From: Peter Seiderer <ps.report@gmx.net>
+Date: Fri, 2 Nov 2018 12:58:57 +0100
+Subject: [PATCH] ell/signal.h: use standard sigset_t, fixes musl compile
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Use standard sigset_t (instead __sigset_t):
+
+- fixes musl compile
+- fies mismatch between header and implementation file
+
+Fixes:
+
+  In file included from ell/main.c:35:0:
+  ell/signal.h:39:40: error: unknown type name ‘__sigset_t’
+   struct l_signal *l_signal_create(const __sigset_t *mask,
+                                          ^~~~~~~~~~
+  In file included from ell/signal.c:35:0:
+  ell/signal.h:39:40: error: unknown type name ‘__sigset_t’
+   struct l_signal *l_signal_create(const __sigset_t *mask,
+                                          ^~~~~~~~~~
+  ell/signal.c:153:29: error: conflicting types for ‘l_signal_create’
+   LIB_EXPORT struct l_signal *l_signal_create(const sigset_t *mask,
+                               ^~~~~~~~~~~~~~~
+  In file included from ell/signal.c:35:0:
+  ell/signal.h:39:18: note: previous declaration of ‘l_signal_create’ was here
+   struct l_signal *l_signal_create(const __sigset_t *mask,
+                    ^~~~~~~~~~~~~~~
+
+Reverts upstream commit [1], superseeded in the next version by [2].
+
+[1] https://git.kernel.org/pub/scm/libs/ell/ell.git/commit/?id=7af8e3ba0ed522897f5a87e6c8f2980f82ff5012
+[2] https://git.kernel.org/pub/scm/libs/ell/ell.git/commit/?id=4a386a10d88ff52097a974167ab889b3fc2add70
+
+Signed-off-by: Peter Seiderer <ps.report@gmx.net>
+---
+ ell/signal.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/ell/signal.h b/ell/signal.h
+index 0d4fdc8..98cf0fa 100644
+--- a/ell/signal.h
++++ b/ell/signal.h
+@@ -36,7 +36,7 @@ typedef void (*l_signal_notify_cb_t) (struct l_signal *signal,
+                                       uint32_t signo, void *user_data);
+ typedef void (*l_signal_destroy_cb_t) (void *user_data);
+-struct l_signal *l_signal_create(const __sigset_t *mask,
++struct l_signal *l_signal_create(const sigset_t *mask,
+                       l_signal_notify_cb_t callback,
+                       void *user_data, l_signal_destroy_cb_t destroy);
+ void l_signal_remove(struct l_signal *signal);
+-- 
+2.19.1
+
diff --git a/package/ell/Config.in b/package/ell/Config.in
new file mode 100644 (file)
index 0000000..f27d581
--- /dev/null
@@ -0,0 +1,13 @@
+config BR2_PACKAGE_ELL
+       bool "ell"
+       depends on BR2_TOOLCHAIN_HAS_SYNC_4
+       depends on !BR2_STATIC_LIBS
+       depends on BR2_USE_WCHAR
+       help
+         Embedded Linux library (ell)
+
+         https://01.org/ell
+
+comment "ell needs a toolchain w/ dynamic library, wchar"
+       depends on BR2_TOOLCHAIN_HAS_SYNC_4
+       depends on BR2_STATIC_LIBS || !BR2_USE_WCHAR
diff --git a/package/ell/ell.hash b/package/ell/ell.hash
new file mode 100644 (file)
index 0000000..c6b23ba
--- /dev/null
@@ -0,0 +1,5 @@
+# Locally computed
+sha256 8e629347d49d30418e215ccf80f05eb6ff617f752396f93287ed723169aec006 ell-0.13.tar.gz
+
+# License files
+sha256 ec60b993835e2c6b79e6d9226345f4e614e686eb57dc13b6420c15a33a8996e5 COPYING
diff --git a/package/ell/ell.mk b/package/ell/ell.mk
new file mode 100644 (file)
index 0000000..8ea95a6
--- /dev/null
@@ -0,0 +1,27 @@
+################################################################################
+#
+# ell
+#
+################################################################################
+
+ELL_VERSION = 0.13
+ELL_SITE = https://git.kernel.org/pub/scm/libs/ell/ell.git
+ELL_SITE_METHOD = git
+ELL_LICENSE = LGPL-2.1+
+ELL_LICENSE_FILES = COPYING
+ELL_INSTALL_STAGING = YES
+# sources from git, no configure script provided
+ELL_AUTORECONF = YES
+
+# autoreconf requires an existing build-aux directory
+define ELL_MKDIR_BUILD_AUX
+       mkdir -p $(@D)/build-aux
+endef
+ELL_POST_PATCH_HOOKS += ELL_MKDIR_BUILD_AUX
+
+ELL_DEPENDENCIES = host-pkgconf
+
+# disable ell/glib main loop example
+ELL_CONF_OPTS = --disable-glib
+
+$(eval $(autotools-package))