Resolves Bug #182 for buildroot. It works nice to pull in default
author"Steven J. Hill" <sjhill@realitydiluted.com>
Thu, 22 Jun 2006 02:24:08 +0000 (02:24 -0000)
committer"Steven J. Hill" <sjhill@realitydiluted.com>
Thu, 22 Jun 2006 02:24:08 +0000 (02:24 -0000)
configuration files for targets. More information on the bug database
page at <http://bugs.uclibc.org/view.php?id=182>.

Makefile

index 274e0e3356ff98f53daba87a591aaa7ebdedf63a..049b6e5112fc16b1af809feca7247adc067a2d68 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -27,7 +27,8 @@ CONFIG_DEFCONFIG = .defconfig
 CONFIG = package/config
 
 noconfig_targets := menuconfig config oldconfig randconfig \
-       defconfig allyesconfig allnoconfig release tags
+       defconfig allyesconfig allnoconfig release tags    \
+       $(shell find . -name *_defconfig |sed 's/.*\///')
 
 # Pull in the user's configuration file
 ifeq ($(filter $(noconfig_targets),$(MAKECMDGOALS)),)
@@ -184,6 +185,10 @@ allnoconfig: $(CONFIG)/conf
 defconfig: $(CONFIG)/conf
        @$(CONFIG)/conf -d $(CONFIG_CONFIG_IN)
 
+%_defconfig: $(CONFIG)/conf
+       cp $(shell find . -name $@) .config
+       @$(CONFIG)/conf -o $(CONFIG_CONFIG_IN)
+
 #############################################################
 #
 # Cleanup and misc junk