python: Don't delete .py files unless asked.
authorWill Newton <will.newton@gmail.com>
Thu, 17 Sep 2009 16:45:11 +0000 (17:45 +0100)
committerWill Newton <will.newton@gmail.com>
Sun, 20 Sep 2009 18:34:48 +0000 (19:34 +0100)
If we have set BR2_PACKAGE_PYTHON_PY_ONLY or BR2_PACKAGE_PYTHON_PY_PYC
we want .py files to be left on the target, whatever the value of
BR2_PACKAGE_PYTHON_DEV.

Signed-off-by: Will Newton <will.newton@gmail.com>
package/python/python.mk

index cd1ccece3c13c6f6382382154d52994636d29593..95586ad64c6381e82313f819b3769656cf27f695 100644 (file)
@@ -155,7 +155,6 @@ endif
 ifneq ($(BR2_PACKAGE_PYTHON_DEV),y)
        rm -rf $(TARGET_DIR)/usr/include/python$(PYTHON_VERSION_MAJOR)
        rm -rf $(TARGET_DIR)/usr/lib/python$(PYTHON_VERSION_MAJOR)/config
-       find $(TARGET_DIR)/usr/lib/ -name '*.py' -exec rm {} \;
 endif
 ifneq ($(BR2_PACKAGE_PYTHON_BSDDB),y)
        rm -rf $(TARGET_DIR)/usr/lib/python$(PYTHON_VERSION_MAJOR)/bsddb