libssh: bump to version 0.7.2
authorBaruch Siach <baruch@tkos.co.il>
Thu, 1 Oct 2015 18:30:48 +0000 (21:30 +0300)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 2 Oct 2015 14:41:02 +0000 (16:41 +0200)
Also, require threads support. cmake detects threads support correctly, but
libssh build system uses this information incorrectly.

Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/libssh/Config.in
package/libssh/libssh.hash
package/libssh/libssh.mk

index 30aabd621fb6ba2da10c3c43c149769aa170b7ff..3357fb9e925210cb3ecd7289d9408fe3eaa9fd73 100644 (file)
@@ -2,6 +2,7 @@ config BR2_PACKAGE_LIBSSH
        bool "libssh"
        depends on BR2_USE_MMU # fork()
        depends on !BR2_STATIC_LIBS
+       depends on BR2_TOOLCHAIN_HAS_THREADS
        # Either OpenSSL or libgcrypt are mandatory
        select BR2_PACKAGE_LIBGCRYPT if !BR2_PACKAGE_OPENSSL
        help
@@ -12,6 +13,6 @@ config BR2_PACKAGE_LIBSSH
 
          http://www.libssh.org/
 
-comment "libssh needs a toolchain w/ dynamic library"
+comment "libssh needs a toolchain w/ dynamic library, threads"
        depends on BR2_USE_MMU
-       depends on BR2_STATIC_LIBS
+       depends on BR2_STATIC_LIBS || !BR2_TOOLCHAIN_HAS_THREADS
index 473ced36c73b1735bcaa7e1719b61072ece92427..49bf6c959fe2d88fc2dea777e1539daf28da8c90 100644 (file)
@@ -1,4 +1,4 @@
 # from https://red.libssh.org/projects/libssh/files/
-md5    bffc9dc548c3bae3a3afc5ac1654b272        libssh-0.7.1.tar.xz
-# Locally calculated
-sha256 2fc7ccf96d3263cbd8ab520118cb94d9a2e11714c61e22b3f761fc5352fd046d  libssh-0.7.1.tar.xz
+md5    5d7d468937649a6dfc6186edfff083db        libssh-0.7.2.tar.xz
+# Locally calculated after checking signature on uncompressed libssh-0.7.2.tar
+sha256 a32c45b9674141cab4bde84ded7d53e931076c6b0f10b8fd627f3584faebae62  libssh-0.7.2.tar.xz
index cd537b04fc995c7282f5287dc069b4fa0ae4fd01..d425ff0b74bcdb079a0491f5dd9ba0e8508d4e63 100644 (file)
@@ -4,9 +4,9 @@
 #
 ################################################################################
 
-LIBSSH_VERSION = 0.7.1
+LIBSSH_VERSION = 0.7.2
 LIBSSH_SOURCE = libssh-$(LIBSSH_VERSION).tar.xz
-LIBSSH_SITE = https://red.libssh.org/attachments/download/154
+LIBSSH_SITE = https://red.libssh.org/attachments/download/177
 LIBSSH_LICENSE = LGPLv2.1
 LIBSSH_LICENSE_FILES = COPYING
 LIBSSH_INSTALL_STAGING = YES