lvm2: do not override CC and similar variables
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 15 May 2010 18:04:02 +0000 (20:04 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 20 May 2010 20:34:29 +0000 (22:34 +0200)
Since lvm2 uses autoconf, there's no point in overriding CC and other
variables at build time. This causes build breakage as CFLAGS aren't
used at link time, therefore --sysroot lacks, which breaks the build
with external toolchains.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/lvm2/lvm2.mk

index bc6f458720a84d900034088b217ea45529291afa..2bd6b8bcfc644fd3c8213603078be1043c6ebba5 100644 (file)
@@ -74,7 +74,7 @@ $(LVM2_DIR)/.configured: $(LVM2_DIR)/.unpacked
 
 
 $(LVM2_DIR)/.built: $(LVM2_DIR)/.configured
-       $(MAKE1) CC=$(TARGET_CC) RANLIB=$(TARGET_RANLIB) AR=$(TARGET_AR) -C $(LVM2_DIR) DESTDIR=$(STAGING_DIR)
+       $(MAKE1) -C $(LVM2_DIR) DESTDIR=$(STAGING_DIR)
        $(MAKE1) -C $(LVM2_DIR) DESTDIR=$(STAGING_DIR) install
        # Fixup write permissions so that the files can be overwritten
        # several times in the $(TARGET_DIR)