collectd: add cpusleep plugin support
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 22 Dec 2016 01:59:14 +0000 (22:59 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 23 Dec 2016 21:37:31 +0000 (22:37 +0100)
Add explicit support for the new cpusleep dependency-less plugin.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/collectd/Config.in
package/collectd/collectd.mk

index 5e84aa5c5d132e09823ffa453e6af725dafc1092..d1b85aadbe318a107691f93a39ec4475032bd1f2 100644 (file)
@@ -157,6 +157,11 @@ config BR2_PACKAGE_COLLECTD_CPUFREQ
        help
          Collects the current CPU's frequency.
 
+config BR2_PACKAGE_COLLECTD_CPUSLEEP
+       bool "cpusleep"
+       help
+         Measures time spent by CPU in deep sleep mode.
+
 config BR2_PACKAGE_COLLECTD_CURL
        bool "curl"
        select BR2_PACKAGE_LIBCURL
index 5018fb062847ec3e5fa0317b07a3a4208bd0118e..d8b2576c900f112dc393090ec1c40030732986fa 100644 (file)
@@ -41,6 +41,7 @@ COLLECTD_CONF_OPTS += \
        $(if $(BR2_PACKAGE_COLLECTD_CONTEXTSWITCH),--enable-contextswitch,--disable-contextswitch) \
        $(if $(BR2_PACKAGE_COLLECTD_CPU),--enable-cpu,--disable-cpu) \
        $(if $(BR2_PACKAGE_COLLECTD_CPUFREQ),--enable-cpufreq,--disable-cpufreq) \
+       $(if $(BR2_PACKAGE_COLLECTD_CPUSLEEP),--enable-cpusleep,--disable-cpusleep) \
        $(if $(BR2_PACKAGE_COLLECTD_CSV),--enable-csv,--disable-csv) \
        $(if $(BR2_PACKAGE_COLLECTD_CURL),--enable-curl,--disable-curl) \
        $(if $(BR2_PACKAGE_COLLECTD_CURL_JSON),--enable-curl_json,--disable-curl_json) \