package/qemu: disable libssh for the host variant
authorRomain Naour <romain.naour@gmail.com>
Mon, 6 Apr 2020 14:21:56 +0000 (16:21 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Mon, 6 Apr 2020 18:18:06 +0000 (20:18 +0200)
There is no host-libssh in Buildroot, avoid qemu build system
to find libssh from the host.

Under certain circumstances (host distribution, openssl version), the
qemu-system binary fail to start:

host/bin/qemu-system-aarch64: symbol lookup error: /lib64/libssh.so.4: undefined symbol: EVP_KDF_ctrl, version OPENSSL_1_1_1b

$ ldd output/host/bin/qemu-system-aarch64
[...]
libssh.so.4 => /lib64/libssh.so.4

Explicitely disable libssh for the host variant.

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/qemu/qemu.mk

index b2249ed4ee2038d0699f73f780ee9880f5d00ab7..3c3b098a5be9a86041fde48d792e8cce5476da08 100644 (file)
@@ -303,6 +303,7 @@ define HOST_QEMU_CONFIGURE_CMDS
                --extra-cflags="$(HOST_QEMU_CFLAGS)" \
                --extra-ldflags="$(HOST_LDFLAGS)" \
                --python=$(HOST_DIR)/bin/python3 \
+               --disable-libssh \
                $(HOST_QEMU_OPTS)
 endef