gstreamer-good: add speex dependancy
authorJulien Boibessot <julien.boibessot@armadeus.com>
Fri, 12 Feb 2010 22:47:37 +0000 (23:47 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 17 Feb 2010 10:26:09 +0000 (11:26 +0100)
Otherwise, even if speex is selected, as gstreamer is compiled first,
speex plugin is not activated/built.

Signed-off-by: Julien Boibessot <julien.boibessot@armadeus.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
package/multimedia/gst-plugins-good/Config.in
package/multimedia/gst-plugins-good/gst-plugins-good.mk

diff --git a/CHANGES b/CHANGES
index 130ebf057a45bbd1161743cec1902758ea76a7ae..37bc22c1b61c778036917c0b6e22e338c382f8ef 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -2,8 +2,8 @@
 
        Fixes all over the tree and new features.
 
-       Updated/fixed packages: alsa-lib, argus, at, libpcap, rsync, tcl,
-       xproto_trapproto
+       Updated/fixed packages: alsa-lib, argus, at, gst-plugins-good,
+       libpcap, rsync, tcl, xproto_trapproto
 
 2010.02-rc1, Released February 9th, 2010:
 
index fdb6646ae2a04ee0a39ec90901734696129d99a5..a326dc9335f2e80ef963e4f61eb5f2e43b0a5398 100644 (file)
@@ -172,4 +172,8 @@ config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_SOUPHTTPSRC
        bool "souphttpsrc (http client)"
        select BR2_PACKAGE_LIBSOUP
 
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_SPEEX
+       bool "speex"
+       select BR2_PACKAGE_SPEEX
+
 endif
index 7b6f02bea440cecc09091ff69f37bbb51acf37e3..19a53e6e28a6d4381c762abb1a037dd186948a77 100644 (file)
@@ -318,4 +318,11 @@ else
 GST_PLUGINS_GOOD_CONF_OPT += --disable-soup
 endif
 
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_SPEEX),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-speex
+GST_PLUGINS_GOOD_DEPENDENCIES += speex
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-speex
+endif
+
 $(eval $(call AUTOTARGETS,package/multimedia,gst-plugins-good))