package/libsigrok: add optional hidapi dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 11 Jan 2020 15:07:49 +0000 (16:07 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 12 Jan 2020 21:45:21 +0000 (22:45 +0100)
hidapi dependency has been added since version 0.5.2 and
https://github.com/sigrokproject/libsigrok/commit/4417074c68ce998c2d666fc8a034204a1b74fc2f

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/libsigrok/libsigrok.mk

index 4866ec4d68165161e6e84410fefc5b1dcbc79205..8def692e318079ab8ef513539f1dc492fad08761 100644 (file)
@@ -22,6 +22,13 @@ else
 LIBSIGROK_CONF_OPTS += --without-libbluez
 endif
 
+ifeq ($(BR2_PACKAGE_HIDAPI),y)
+LIBSIGROK_CONF_OPTS += --with-libhidapi
+LIBSIGROK_DEPENDENCIES += hidapi
+else
+LIBSIGROK_CONF_OPTS += --without-libhidapi
+endif
+
 ifeq ($(BR2_PACKAGE_LIBSERIALPORT),y)
 LIBSIGROK_CONF_OPTS += --with-libserialport
 LIBSIGROK_DEPENDENCIES += libserialport