gst1-plugins-bad: remove rtp plugin option
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Tue, 3 May 2016 19:44:15 +0000 (16:44 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 5 May 2016 06:29:33 +0000 (08:29 +0200)
The plugin was moved from -bad to -good so remove the option.
Support in -good was added via 301e8ffb.
Add legacy entry to notify users of this, however we can't automatically
select the good variant since good might be disabled.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Config.in.legacy
package/gstreamer1/gst1-plugins-bad/Config.in
package/gstreamer1/gst1-plugins-bad/gst1-plugins-bad.mk

index 9901cf6f39daef18f97d2de36e7de23e0ecc31af..5317dde9882127306d3d2a8e138521537f75ee5d 100644 (file)
@@ -145,6 +145,13 @@ endif
 ###############################################################################
 comment "Legacy options removed in 2016.05"
 
+config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_RTP
+       bool "gst1-plugins-bad rtp plugin moved to good"
+       select BR2_LEGACY
+       help
+         The rtp plugin has been moved from gst1-plugins-base to
+         gst1-plugins-good.
+
 config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_MPG123
        bool "gst1-plugins-bad mpg123 plugin moved to ugly"
        select BR2_LEGACY
index 16bb36d1f93d9c51c7b053c8d56105e2b2a1e5ce..53ce589d3a0303061a7e7ac64c69dae799b4a7cc 100644 (file)
@@ -382,9 +382,6 @@ config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_REMOVESILENCE
        help
          Removes silence from an audio stream
 
-config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_RTP
-       bool "rtp"
-
 config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_SDI
        bool "sdi"
 
index 80bdee8b36d7272918c44f6a541aad107bf5154d..6d8cac7c2a15745576ec5256f5e5a8d1259a3700 100644 (file)
@@ -479,12 +479,6 @@ else
 GST1_PLUGINS_BAD_CONF_OPTS += --disable-removesilence
 endif
 
-ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_RTP),y)
-GST1_PLUGINS_BAD_CONF_OPTS += --enable-rtp
-else
-GST1_PLUGINS_BAD_CONF_OPTS += --disable-rtp
-endif
-
 ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_SDI),y)
 GST1_PLUGINS_BAD_CONF_OPTS += --enable-sdi
 else