package/vlc: add optional support for libvncserver
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 28 Feb 2016 20:18:24 +0000 (21:18 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 5 Mar 2016 14:01:53 +0000 (15:01 +0100)
When libvncserver was compiled before, vlc will use it as optional
dependency:

$ output/host/usr/bin/x86_64-linux-readelf -a output/target/usr/lib/vlc/plugins/access/libvnc_plugin.so | grep NEEDED
 0x0000000000000001 (NEEDED)             Shared library: [libvlccore.so.8]
 0x0000000000000001 (NEEDED)             Shared library: [librt.so.1]
 0x0000000000000001 (NEEDED)             Shared library: [libintl.so.8]
 0x0000000000000001 (NEEDED)             Shared library: [libdl.so.1]
 0x0000000000000001 (NEEDED)             Shared library: [libvncclient.so.0]
[...]

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/vlc/vlc.mk

index 1bb2b93c1d7e041d298d4fa29f83faf7b080e30a..4affb8748f1e59d5fb057103fb5bdce6dcf3891f 100644 (file)
@@ -272,6 +272,13 @@ else
 VLC_CONF_OPTS += --disable-upnp
 endif
 
+ifeq ($(BR2_PACKAGE_LIBVNCSERVER),y)
+VLC_CONF_OPTS += --enable-vnc
+VLC_DEPENDENCIES += libvncserver
+else
+VLC_CONF_OPTS += --disable-vnc
+endif
+
 ifeq ($(BR2_PACKAGE_LIBVORBIS),y)
 VLC_CONF_OPTS += --enable-vorbis
 VLC_DEPENDENCIES += libvorbis