package/tor: add optional support for lzma
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sat, 23 Sep 2017 08:46:28 +0000 (10:46 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Tue, 26 Sep 2017 20:46:58 +0000 (22:46 +0200)
According to https://blog.torproject.org/tor-0317-now-released
we also need host-pkgconf for lzma support.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/tor/tor.mk

index a68f29cac6049721cdc71138b8ebe22f8d9a40c3..6052e09cf1cec74242298b062d15f5a3790cb8ef 100644 (file)
@@ -30,6 +30,13 @@ ifeq ($(BR2_PACKAGE_LIBCAP),y)
 TOR_DEPENDENCIES += libcap
 endif
 
+ifeq ($(BR2_PACKAGE_XZ),y)
+TOR_CONF_OPTS += --enable-lzma
+TOR_DEPENDENCIES += host-pkgconf xz
+else
+TOR_CONF_OPTS += --disable-lzma
+endif
+
 ifeq ($(BR2_arm)$(BR2_armeb)$(BR2_i386)$(BR2_x86_64)$(BR2_PACKAGE_LIBSECCOMP),yy)
 TOR_CONF_OPTS += --enable-seccomp
 TOR_DEPENDENCIES += libseccomp