libselinux: use $(HOST_MAKE_ENV) when calling $(MAKE)
authorGustavo Zacarias <gustavo.zacarias@free-electrons.com>
Fri, 28 Oct 2016 13:18:23 +0000 (10:18 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 29 Oct 2016 13:52:40 +0000 (15:52 +0200)
Signed-off-by: Gustavo Zacarias <gustavo.zacarias@free-electrons.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libselinux/libselinux.mk

index 29ed0efacf1b89d04c146d8a4ac985f13d100825..165ac4c30d82f80bb3cb67bb11984d091af6d354 100644 (file)
@@ -67,18 +67,22 @@ HOST_LIBSELINUX_MAKE_OPTS = \
 define HOST_LIBSELINUX_BUILD_CMDS
        # DESTDIR is needed during the compile to compute library and
        # header paths.
-       $(MAKE1) -C $(@D) $(HOST_LIBSELINUX_MAKE_OPTS) DESTDIR=$(HOST_DIR) \
+       $(HOST_MAKE_ENV) $(MAKE1) -C $(@D) \
+               $(HOST_LIBSELINUX_MAKE_OPTS) DESTDIR=$(HOST_DIR) \
                SHLIBDIR=$(HOST_DIR)/usr/lib all
        # Generate python interface wrapper
-       $(MAKE1) -C $(@D) $(HOST_LIBSELINUX_MAKE_OPTS) DESTDIR=$(HOST_DIR) swigify pywrap
+       $(HOST_MAKE_ENV) $(MAKE1) -C $(@D) \
+               $(HOST_LIBSELINUX_MAKE_OPTS) DESTDIR=$(HOST_DIR) swigify pywrap
 endef
 
 define HOST_LIBSELINUX_INSTALL_CMDS
-       $(MAKE) -C $(@D) $(HOST_LIBSELINUX_MAKE_OPTS) DESTDIR=$(HOST_DIR) \
+       $(HOST_MAKE_ENV) $(MAKE) -C $(@D) \
+               $(HOST_LIBSELINUX_MAKE_OPTS) DESTDIR=$(HOST_DIR) \
                SHLIBDIR=$(HOST_DIR)/usr/lib SBINDIR=$(HOST_DIR)/usr/sbin install
        (cd $(HOST_DIR)/usr/lib; $(HOSTLN) -sf libselinux.so.1 libselinux.so)
        # Install python interface wrapper
-       $(MAKE) -C $(@D) $(HOST_LIBSELINUX_MAKE_OPTS) DESTDIR=$(HOST_DIR) install-pywrap
+       $(HOST_MAKE_ENV) $(MAKE) -C $(@D) \
+               $(HOST_LIBSELINUX_MAKE_OPTS) DESTDIR=$(HOST_DIR) install-pywrap
 endef
 
 $(eval $(generic-package))