package/sdl2_ttf: x-includes and x-libraries must be set for cross-compiling
authorRomain Naour <romain.naour@gmail.com>
Sat, 23 Jul 2016 10:19:42 +0000 (12:19 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 24 Jul 2016 13:03:31 +0000 (15:03 +0200)
If those flags are not explicitly passed, the sdl2_ttf configure script
will include -I/usr/include and -L/usr/lib in the compile flags, which
are obviously unsafe for cross-compilation.

"checking for X... libraries /usr/lib, headers /usr/include"

Fixes:

  http://autobuild.buildroot.net/results/f968fb31e9882cc856296a7c729d93e345e9e861

Signed-off-by: Romain Naour <romain.naour@gmail.com>
[Thomas:
 - don't pass an argument to --with-x
 - use --without-x instead of --with-x=no]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/sdl2_ttf/sdl2_ttf.mk

index 71c5bc7a44ef7044547d2abb9861c7e35512a980..6834d16cb21166e77e63205c75431f7cf864117e 100644 (file)
@@ -14,4 +14,17 @@ SDL2_TTF_DEPENDENCIES = sdl2 freetype host-pkgconf
 SDL2_TTF_CONF_ENV = \
        FREETYPE_CONFIG=$(STAGING_DIR)/usr/bin/freetype-config
 
+# x-includes and x-libraries must be set for cross-compiling
+# By default x_includes and x_libraries contains unsafe paths.
+# (/usr/include and /usr/lib)
+ifeq ($(BR2_PACKAGE_SDL2_X11),y)
+SDL2_TTF_CONF_OPTS += \
+       --with-x \
+       --x-includes=$(STAGING_DIR)/usr/include \
+       --x-libraries=$(STAGING_DIR)/usr/lib
+else
+SDL2_TTF_CONF_OPTS += \
+       --without-x
+endif
+
 $(eval $(autotools-package))