bash: build after busybox
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Tue, 11 Jan 2011 17:38:24 +0000 (14:38 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 17 Jan 2011 20:06:38 +0000 (21:06 +0100)
Make sure bash builds after busybox when it's enabled to override
busybox's /bin/sh symlink with bash.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/bash/bash.mk

index d7bb699e158c16168bd14b51cb7caa7f4b79fe76..2bcf0c43a75698aa79cb40e517c6b80e178c25c6 100644 (file)
@@ -8,6 +8,11 @@ BASH_VERSION = 4.1
 BASH_SITE = $(BR2_GNU_MIRROR)/bash
 BASH_DEPENDENCIES = ncurses
 
+# Make sure we build after busybox so that /bin/sh links to bash
+ifeq ($(BR2_PACKAGE_BUSYBOX),y)
+BASH_DEPENDENCIES += busybox
+endif
+
 # Save the old sh file/link if there is one and symlink bash->sh
 define BASH_INSTALL_TARGET_CMDS
        $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) \