package/avahi: Set the path to D-Bus system.d directory
authorChris Lesiak <chris.lesiak@licor.com>
Tue, 23 Jan 2018 23:17:23 +0000 (17:17 -0600)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 26 Mar 2018 20:53:45 +0000 (22:53 +0200)
Since D-Bus 1.9.18, the recommended location for the system and
session busses configuration files is /usr/share instead of /etc. From
the D-Bus NEWS file:

D-Bus 1.9.18 (2015-07-21)
==

The “Pirate Elite” release.

Configuration changes:

• The basic setup for the well-known system and session buses is now done
   in read-only files in ${datadir}, moving a step closer to systems
   that can operate with an empty /etc directory. In increasing order
   of precedence:

   · ${datadir}/dbus-1/s*.conf now perform the basic setup such as setting
     the default message policies.
   · ${sysconfdir}/dbus-1/s*.conf are now optional. By default
     dbus still installs a trivial version of each, for documentation
     purposes; putting configuration directives in these files is
     deprecated.
   · ${datadir}/dbus-1/s*.d/ are now available for third-party software
     to install "drop-in" configuration snippets (any packages
     using those directories should explicitly depend on at least this
     version of dbus).
   · ${sysconfdir}/dbus-1/s*.d/ are also still available for sysadmins
     or third-party software to install "drop-in" configuration snippets
   · ${sysconfdir}/dbus-1/s*-local.conf are still available for sysadmins'
     overrides

   ${datadir} is normally /usr/share, ${sysconfdir} is normally /etc,
   and "s*" refers to either system or session as appropriate.

Therefore, this commit adjusts the Avahi package to install the D-Bus
related files to /usr/share/dbus-1/system.d.

Signed-off-by: Chris Lesiak <chris.lesiak@licor.com>
Reviewed-by: Samuel Martin <s.martin49@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/avahi/avahi.mk

index c8f1af9a9dc4fc27ea00c474acb68bc491341b29..ef621620f0cc1bebf43d65fa9be1e2d18c9b573e 100644 (file)
@@ -125,6 +125,7 @@ endif
 
 ifeq ($(BR2_PACKAGE_DBUS),y)
 AVAHI_DEPENDENCIES += dbus
+AVAHI_CONF_OPTS += --with-dbus-sys=/usr/share/dbus-1/system.d
 else
 AVAHI_CONF_OPTS += --disable-dbus
 endif