gtest: retrieve package from github
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Wed, 31 Aug 2016 16:29:54 +0000 (18:29 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 6 Sep 2016 20:55:53 +0000 (22:55 +0200)
https://googletest.googlecode.com/files is no more available, so update
gtest.mk and gtest.hash to retrieve googletest source code as a tar.gz
(and not a zip) from github as https://googletest.googlecode.com is now
a redirection to https://github.com/google/googletest.

Signed-off-by: Fabrice Fontaine <fabrice.fontaine@orange.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/gtest/gtest.hash
package/gtest/gtest.mk

index 8ff79cb0d61a43c9ec485f42c8d2c3f72ee595da..79e31e466d20010e4d940959117bc8b25758e8a5 100644 (file)
@@ -1,2 +1,2 @@
-# From http://code.google.com/p/googletest/downloads/detail?name=gtest-1.7.0.zip&can=2&q=
-sha1   f85f6d2481e2c6c4a18539e391aa4ea8ab0394af        gtest-1.7.0.zip
+# Locally computed:
+sha256 f73a6546fdf9fce9ff93a5015e0333a8af3062a152a9ad6bcb772c96687016cc        gtest-release-1.7.0.tar.gz
index 11aa7e9baed1dc2a8fc11a20807947991c49c3dd..eb30905c2afa5b2f1e9e20f6da867b062ce99d1c 100644 (file)
@@ -5,9 +5,8 @@
 ################################################################################
 
 # Make sure this remains the same version as the gmock one
-GTEST_VERSION = 1.7.0
-GTEST_SOURCE = gtest-$(GTEST_VERSION).zip
-GTEST_SITE = http://googletest.googlecode.com/files
+GTEST_VERSION = release-1.7.0
+GTEST_SITE = $(call github,google,googletest,$(GTEST_VERSION))
 GTEST_INSTALL_STAGING = YES
 GTEST_INSTALL_TARGET = NO
 GTEST_LICENSE = BSD-3c
@@ -22,10 +21,6 @@ GTEST_LICENSE_FILES = LICENSE
 # the gtest sources.
 GTEST_CONF_OPTS = -DBUILD_SHARED_LIBS=OFF
 
-define GTEST_EXTRACT_CMDS
-       $(UNZIP) $(DL_DIR)/$(GTEST_SOURCE) -d $(BUILD_DIR)
-endef
-
 define GTEST_INSTALL_STAGING_CMDS
        $(INSTALL) -D -m 0755 $(@D)/libgtest.a $(STAGING_DIR)/usr/lib/libgtest.a
        $(INSTALL) -D -m 0755 $(@D)/libgtest_main.a $(STAGING_DIR)/usr/lib/libgtest_main.a