Add an optional ncurses-headers target to install target header files
authorEric Andersen <andersen@codepoet.org>
Wed, 8 Jan 2003 02:29:25 +0000 (02:29 -0000)
committerEric Andersen <andersen@codepoet.org>
Wed, 8 Jan 2003 02:29:25 +0000 (02:29 -0000)
 -Erik

make/ncurses.mk

index b021b30e0ee63244abbcc63fb470e9bf4badcd01..420cd3fde443252eb7f639866a110851e76fcbcc 100644 (file)
@@ -5,7 +5,7 @@
 #
 #############################################################
 # Copyright (C) 2002 by Ken Restivo <ken@246gt.com>
-# $Id: ncurses.mk,v 1.10 2003/01/02 08:43:57 andersen Exp $
+# $Id: ncurses.mk,v 1.11 2003/01/08 02:29:25 andersen Exp $
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU Library General Public License as
@@ -72,6 +72,19 @@ $(TARGET_DIR)/lib/libncurses.so: $(STAGING_DIR)/lib/libncurses.so
                        tar -C $(TARGET_DIR)/usr/share/ -xf - ; \
        done
 
+$(TARGET_DIR)/include/curses.h: $(TARGET_DIR)/lib/libncurses.so
+       cp -dpf $(NCURSES_DIR)/include/curses.h $(TARGET_DIR)/include/
+       cp -dpf $(NCURSES_DIR)/include/eti.h $(TARGET_DIR)/include/
+       cp -dpf $(NCURSES_DIR)/include/form.h $(TARGET_DIR)/include/
+       cp -dpf $(NCURSES_DIR)/include/menu.h $(TARGET_DIR)/include/
+       cp -dpf $(NCURSES_DIR)/include/panel.h $(TARGET_DIR)/include/
+       cp -dpf $(NCURSES_DIR)/include/term.h $(TARGET_DIR)/include/
+       cp -dpf $(NCURSES_DIR)/include/termcap.h $(TARGET_DIR)/include/
+       cp -dpf $(NCURSES_DIR)/include/unctrl.h $(TARGET_DIR)/include/
+       (cd $(TARGET_DIR)/include; ln -fs curses.h ncurses.h)
+
+ncurses-headers: $(TARGET_DIR)/include/curses.h
+
 ncurses-clean: 
        rm -f $(STAGING_DIR)/lib/libncurses.so* $(TARGET_DIR)/lib/libncurses.so*
        rm -f $(STAGING_DIR)/usr/share/tabset $(TARGET_DIR)/usr/share/tabset