efivar: force shared libgcc for Nios II
authorErico Nunes <nunes.erico@gmail.com>
Tue, 28 Jun 2016 19:25:20 +0000 (21:25 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 1 Jul 2016 14:19:27 +0000 (16:19 +0200)
efivar for Nios II also has to be linked with shared libgcc to avoid an
error due to FDE encoding in static libgcc when linking libefiboot.so.

Fixes:
http://autobuild.buildroot.net/results/0c9/0c90e3e7ad41d21dd832f6f266af35fc19185170/

Signed-off-by: Erico Nunes <nunes.erico@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/efivar/efivar.mk

index de48bc99712bd600118aa2f0cd06b4c7a3d5ebbb..cb5f7b65ef78a598db8b69822c4dbfec9d1341b1 100644 (file)
@@ -21,9 +21,9 @@ EFIVAR_MAKE_OPTS = \
        BINTARGETS=efivar \
        LDFLAGS="$(TARGET_LDFLAGS) -fPIC"
 
-# Explicitly linking with shared libgcc is required on MicroBlaze,
-# otherwise it fails due to FDE encoding in static libgcc.
-ifeq ($(BR2_microblaze),y)
+# Explicitly linking with shared libgcc is required on MicroBlaze and
+# Nios II, otherwise it fails due to FDE encoding in static libgcc.
+ifeq ($(BR2_microblaze)$(BR2_nios2),y)
 EFIVAR_MAKE_OPTS += SOFLAGS="-shared -shared-libgcc"
 endif