package/nginx: add random modules
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 20 Sep 2020 08:13:54 +0000 (10:13 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 20 Sep 2020 13:31:41 +0000 (15:31 +0200)
http_upstream and stream_upstream random modules are available since
version 1.15.1 and
https://github.com/nginx/nginx/commit/0c4ccbea23813a50132df511d4445bc1686dbc2f
and are enabled by default, add two options to be able to disable them

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/nginx/Config.in
package/nginx/nginx.mk

index 507b4dcfb4469084a99d46d4982ac01917104e94..15e63f4a76abfcd086beb6d673fefc0ee7a2ceb7 100644 (file)
@@ -290,6 +290,12 @@ config BR2_PACKAGE_NGINX_HTTP_UPSTREAM_KEEPALIVE_MODULE
        help
          Enable ngx_http_upstream_keepalive_module
 
+config BR2_PACKAGE_NGINX_HTTP_UPSTREAM_RANDOM_MODULE
+       bool "ngx_http_upstream_random_module"
+       default y
+       help
+         Enable ngx_http_upstream_random_module
+
 endif #BR2_PACKAGE_NGINX_HTTP
 
 config BR2_PACKAGE_NGINX_MAIL
@@ -393,6 +399,12 @@ config BR2_PACKAGE_NGINX_STREAM_UPSTREAM_LEAST_CONN_MODULE
        help
          Enable ngx_stream_upstream_least_conn_module
 
+config BR2_PACKAGE_NGINX_STREAM_UPSTREAM_RANDOM_MODULE
+       bool "ngx_stream_upstream_random_module"
+       default y
+       help
+         Enable ngx_stream_upstream_random_module
+
 config BR2_PACKAGE_NGINX_STREAM_UPSTREAM_ZONE_MODULE
        bool "ngx_stream_upstream_zone_module"
        default y
index 9696d6b37dd444046ed6568d75aee30c2c7fe5ed..06fc49d24693539c217c019ae580f3c392fbd170 100644 (file)
@@ -198,6 +198,7 @@ NGINX_CONF_OPTS += \
        $(if $(BR2_PACKAGE_NGINX_HTTP_BROWSER_MODULE),,--without-http_browser_module) \
        $(if $(BR2_PACKAGE_NGINX_HTTP_UPSTREAM_IP_HASH_MODULE),,--without-http_upstream_ip_hash_module) \
        $(if $(BR2_PACKAGE_NGINX_HTTP_UPSTREAM_LEAST_CONN_MODULE),,--without-http_upstream_least_conn_module) \
+       $(if $(BR2_PACKAGE_NGINX_HTTP_UPSTREAM_RANDOM_MODULE),,--without-http_upstream_random_module) \
        $(if $(BR2_PACKAGE_NGINX_HTTP_UPSTREAM_KEEPALIVE_MODULE),,--without-http_upstream_keepalive_module)
 
 else # !BR2_PACKAGE_NGINX_HTTP
@@ -247,6 +248,7 @@ NGINX_CONF_OPTS += \
        $(if $(BR2_PACKAGE_NGINX_STREAM_RETURN_MODULE),,--without-stream_return_module) \
        $(if $(BR2_PACKAGE_NGINX_STREAM_UPSTREAM_HASH_MODULE),,--without-stream_upstream_hash_module) \
        $(if $(BR2_PACKAGE_NGINX_STREAM_UPSTREAM_LEAST_CONN_MODULE),,--without-stream_upstream_least_conn_module) \
+       $(if $(BR2_PACKAGE_NGINX_STREAM_UPSTREAM_RANDOM_MODULE),,--without-stream_upstream_random_module) \
        $(if $(BR2_PACKAGE_NGINX_STREAM_UPSTREAM_ZONE_MODULE),,--without-stream_upstream_zone_module)
 
 endif # BR2_PACKAGE_NGINX_STREAM