package/mplayer: add optional libfribidi support
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 29 Mar 2015 17:11:23 +0000 (19:11 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 7 Apr 2015 21:17:58 +0000 (23:17 +0200)
[Thomas: rely on autodetection.]

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/mplayer/mplayer.mk

index 7a88b7418cf3a25031a760a83c213003fd3f9139..9f6c1e6d8182eda96f142f367f25cad7aca143a4 100644 (file)
@@ -53,6 +53,14 @@ else
 MPLAYER_CONF_OPTS += --disable-fontconfig
 endif
 
+# We intentionally don't pass --enable-fribidi, to let the
+# autodetection find which library to link with.
+ifeq ($(BR2_PACKAGE_LIBFRIBIDI),y)
+MPLAYER_DEPENDENCIES += libfribidi
+else
+MPLAYER_CONF_OPTS += --disable-fribidi
+endif
+
 # We intentionally don't pass --enable-termcap, in order to let the
 # autodetection find with which library to link with. Otherwise, we
 # would have to pass it manually.