Added ccache support and removed grub from defconfig due to brokenness at the moment.
authorJason Spence <jspence@uclibc.org>
Fri, 28 Mar 2008 02:50:42 +0000 (02:50 -0000)
committerJason Spence <jspence@uclibc.org>
Fri, 28 Mar 2008 02:50:42 +0000 (02:50 -0000)
.defconfig
Makefile

index c98b192e651b578e9228793ef2a2411492275fac..866c60ba1d723cb7a89effc163298af9b5574f65 100644 (file)
@@ -628,8 +628,8 @@ BR2_GAMES=y
 #
 # bootloader for target device
 #
-BR2_TARGET_GRUB=y
-BR2_TARGET_GRUB_SPLASH=y
+# BR2_TARGET_GRUB is not set
+# BR2_TARGET_GRUB_SPLASH is not set
 # BR2_TARGET_GRUB_DISKLESS is not set
 # BR2_TARGET_GRUB_3c595 is not set
 # BR2_TARGET_GRUB_3c90x is not set
index 1aca7885a9fdcdd01bcac465d36b41135e9d59b7..9f9f0628d08db780ede1c9927149155a6719219b 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -78,6 +78,11 @@ CONFIG_SHELL:=$(shell if [ -x "$$BASH" ]; then echo $$BASH; \
 
 export CONFIG_SHELL quiet Q KBUILD_VERBOSE VERBOSE
 
+HOSTCCACHE:=$(shell $(CONFIG_SHELL) -c "which ccache")
+ifneq ($(HOSTCCACHE),)
+BR2_HAVE_HOST_CCACHE=y
+endif
+
 ifndef HOSTAR
 HOSTAR:=ar
 endif
@@ -124,6 +129,12 @@ endif
 ifndef FCFLAGS_FOR_BUILD
 FCFLAGS_FOR_BUILD:=-g -O2
 endif
+
+ifeq ($(BR2_HAVE_HOST_CCACHE),y)
+HOSTCC:=$(HOSTCCACHE) $(HOSTCC)
+HOSTCXX:=$(HOSTCCACHE) $(HOSTCXX)
+endif
+
 export HOSTAR HOSTAS HOSTCC HOSTCXX HOSTFC HOSTLD